aboutsummaryrefslogtreecommitdiff
path: root/www/py-gunicorn
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-03-24 08:59:49 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-03-24 08:59:49 +0000
commit2ef1360363b613489c3d57eb0d9d29ac2f628973 (patch)
tree9d1a324b8df255b83e476ef965ac75ef5b1dfec5 /www/py-gunicorn
parente3818fa7ee32459db64dae76d2a76613b50c1ee7 (diff)
Notes
Diffstat (limited to 'www/py-gunicorn')
-rw-r--r--www/py-gunicorn/Makefile28
-rw-r--r--www/py-gunicorn/distinfo4
-rw-r--r--www/py-gunicorn/pkg-plist3
3 files changed, 15 insertions, 20 deletions
diff --git a/www/py-gunicorn/Makefile b/www/py-gunicorn/Makefile
index be8cdffd3dac..3891d7b29167 100644
--- a/www/py-gunicorn/Makefile
+++ b/www/py-gunicorn/Makefile
@@ -2,30 +2,29 @@
# $FreeBSD$
PORTNAME= gunicorn
-PORTVERSION= 0.16.1
+PORTVERSION= 0.17.2
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Python WSGI server for unix
+COMMENT= Python WSGI server for UNIX
LICENSE= MIT
-USE_GITHUB= yes
-GH_ACCOUNT= benoitc
-GH_TAGNAME= 0.16.1
-GH_COMMIT= 0d91a51
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
-# Python3 Ready
+USE_GITHUB= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-OPTIONS_DEFINE= EVENTLET GEVENT TORNADO SETPROC TESTS
+GH_ACCOUNT= benoitc
+GH_COMMIT= 5369c6c
+
+OPTIONS_DEFINE= EVENTLET GEVENT TORNADO SETPROC
EVENTLET_DESC= Add Eventlet async worker
GEVENT_DESC= Add Gevent async worker
TORNADO_DESC= Add Tornado async worker
SETPROC_DESC= Support changing process title (setproctitle)
-TESTS_DESC= Install tools for running unittests
OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
NO_OPTIONS_SORT= yes
@@ -33,11 +32,11 @@ NO_OPTIONS_SORT= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MEVENTLET}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9:${PORTSDIR}/net/py-eventlet
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.7:${PORTSDIR}/net/py-eventlet
.endif
.if ${PORT_OPTIONS:MGEVENT}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gevent>0:${PORTSDIR}/devel/py-gevent
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gevent>=0.12.2:${PORTSDIR}/devel/py-gevent
.endif
.if ${PORT_OPTIONS:MTORNADO}
@@ -48,13 +47,6 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.2:${PORTSDIR}/www/py-tornado
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setproctitle>0:${PORTSDIR}/devel/py-setproctitle
.endif
-.if ${PORT_OPTIONS:MTESTS}
-BUILD_DEPENDS:= ${TEST_DEPENDS} \
- ${RUN_DEPENDS}
-.endif
-
-TEST_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
-
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
diff --git a/www/py-gunicorn/distinfo b/www/py-gunicorn/distinfo
index dd98e73a93bb..059e5672d7f4 100644
--- a/www/py-gunicorn/distinfo
+++ b/www/py-gunicorn/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gunicorn-0.16.1.tar.gz) = e1972878b7a742302fb5281cb4d4c64f4c0eace2c58a814e88bd09754149ff40
-SIZE (gunicorn-0.16.1.tar.gz) = 333263
+SHA256 (gunicorn-0.17.2.tar.gz) = 9483f2adfde0659ef42ad47da9417aaf4417aa672ab8da3185149f0489db03d1
+SIZE (gunicorn-0.17.2.tar.gz) = 360240
diff --git a/www/py-gunicorn/pkg-plist b/www/py-gunicorn/pkg-plist
index 43ac7b122fb7..72159b9dd6a8 100644
--- a/www/py-gunicorn/pkg-plist
+++ b/www/py-gunicorn/pkg-plist
@@ -31,6 +31,9 @@ bin/gunicorn_paster
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/arbiter.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/arbiter.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/arbiter.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/argparse_compat.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/argparse_compat.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/argparse_compat.pyo
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/config.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/config.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/gunicorn/config.pyo