aboutsummaryrefslogtreecommitdiff
path: root/www/py-httpx
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-01 22:16:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-01 22:19:23 +0000
commit8b5d093d146ae77efa845f956940e1ae44a69a90 (patch)
tree6d2b991489c37788e84477ff119e60ca3f1033fa /www/py-httpx
parentff7e3d70d89e5a4751823ced73504b4f2ee00067 (diff)
downloadports-8b5d093d146ae77efa845f956940e1ae44a69a90.tar.gz
ports-8b5d093d146ae77efa845f956940e1ae44a69a90.zip
Diffstat (limited to 'www/py-httpx')
-rw-r--r--www/py-httpx/Makefile5
-rw-r--r--www/py-httpx/distinfo6
-rw-r--r--www/py-httpx/files/patch-setup.py10
3 files changed, 8 insertions, 13 deletions
diff --git a/www/py-httpx/Makefile b/www/py-httpx/Makefile
index 7eea1fd748b8..d9d5c0b9758d 100644
--- a/www/py-httpx/Makefile
+++ b/www/py-httpx/Makefile
@@ -1,8 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= httpx
-PORTVERSION= 0.17.1
-PORTREVISION= 1
+PORTVERSION= 0.18.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}httpcore>=0.12.1<0.14:www/py-httpcore@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httpcore>=0.13.0<0.14:www/py-httpcore@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=0:dns/py-idna@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rfc3986>=1.3<2:www/py-rfc3986@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sniffio>=0:devel/py-sniffio@${PY_FLAVOR}
diff --git a/www/py-httpx/distinfo b/www/py-httpx/distinfo
index f0c0611499c9..307f46e51faf 100644
--- a/www/py-httpx/distinfo
+++ b/www/py-httpx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618320308
-SHA256 (httpx-0.17.1.tar.gz) = cc2a55188e4b25272d2bcd46379d300f632045de4377682aa98a8a6069d55967
-SIZE (httpx-0.17.1.tar.gz) = 86489
+TIMESTAMP = 1619725375
+SHA256 (httpx-0.18.0.tar.gz) = 46cfb242ae6b85c3f21f7774cb42a465acdf73741e49f6746ab481f16d0e0590
+SIZE (httpx-0.18.0.tar.gz) = 94859
diff --git a/www/py-httpx/files/patch-setup.py b/www/py-httpx/files/patch-setup.py
index 836464d0a902..1bd6a60e5e49 100644
--- a/www/py-httpx/files/patch-setup.py
+++ b/www/py-httpx/files/patch-setup.py
@@ -1,11 +1,7 @@
---- setup.py.orig 2021-03-15 09:19:02 UTC
+--- setup.py.orig 2021-04-27 14:22:26 UTC
+++ setup.py
-@@ -59,10 +59,10 @@ setup(
- "certifi",
- "sniffio",
- "rfc3986[idna2008]>=1.3,<2",
-- "httpcore>=0.12.1,<0.13",
-+ "httpcore>=0.12.1,<0.14",
+@@ -63,7 +63,7 @@ setup(
+ "async_generator; python_version < '3.7'"
],
extras_require={
- "http2": "h2==3.*",