aboutsummaryrefslogtreecommitdiff
path: root/www/py-livereload/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-06 07:20:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-06 07:20:03 +0000
commitb58f4d3815bfe2d5fa54ab28c1ec063d58c638c9 (patch)
tree31218a3facf6417ace7e167a70599413ff8941fc /www/py-livereload/Makefile
parent5ae4a6cad802d174baedc51d76bf03a4bb9e575b (diff)
downloadports-b58f4d3815bfe2d5fa54ab28c1ec063d58c638c9.tar.gz
ports-b58f4d3815bfe2d5fa54ab28c1ec063d58c638c9.zip
Notes
Diffstat (limited to 'www/py-livereload/Makefile')
-rw-r--r--www/py-livereload/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/py-livereload/Makefile b/www/py-livereload/Makefile
new file mode 100644
index 000000000000..0e35a1ac0761
--- /dev/null
+++ b/www/py-livereload/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= livereload
+DISTVERSION= 2.5.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= WSGI for web developers to watch changes in realtime
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>