aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.app.layout/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-02 21:06:12 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-02 21:06:12 +0000
commit4b5c3cdd17e996e5bca5ceeecf864c8416dabcc3 (patch)
tree50f11365bd39355323f5c6cab4fa7d8feb293e7a /www/py-plone.app.layout/Makefile
parent10c2150c7735c8fb732f96e05ab7116b37f21f1b (diff)
downloadports-4b5c3cdd17e996e5bca5ceeecf864c8416dabcc3.tar.gz
ports-4b5c3cdd17e996e5bca5ceeecf864c8416dabcc3.zip
Notes
Diffstat (limited to 'www/py-plone.app.layout/Makefile')
-rw-r--r--www/py-plone.app.layout/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/www/py-plone.app.layout/Makefile b/www/py-plone.app.layout/Makefile
new file mode 100644
index 000000000000..59694ef56162
--- /dev/null
+++ b/www/py-plone.app.layout/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: py-plone.app.layout
+# Date created: 03 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.app.layout
+PORTVERSION= 2.2.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Layout mechanisms for Plone
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.app.viewletmanager>=1.2:${PORTSDIR}/www/py-plone.app.viewletmanager \
+ ${PYTHON_PKGNAMEPREFIX}plone.i18n>=0:${PORTSDIR}/www/py-plone.i18n \
+ ${PYTHON_PKGNAMEPREFIX}plone.locking>=0:${PORTSDIR}/www/py-plone.locking \
+ ${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.memoize \
+ ${PYTHON_PKGNAMEPREFIX}plone.portlets>=0:${PORTSDIR}/www/py-plone.portlets \
+ ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope.annotation \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.deprecation>=0:${PORTSDIR}/devel/py-zope.deprecation \
+ ${PYTHON_PKGNAMEPREFIX}zope.dottedname>=0:${PORTSDIR}/devel/py-zope.dottedname \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18n>=0:${PORTSDIR}/devel/py-zope.i18n \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.viewlet>=0:${PORTSDIR}/devel/py-zope.viewlet \
+ ${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition \
+ ${PYTHON_PKGNAMEPREFIX}DateTime>=0:${PORTSDIR}/devel/py-DateTime \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=0:${PORTSDIR}/devel/py-Products.CMFCore \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFDefault>=0:${PORTSDIR}/devel/py-Products.CMFDefault \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFDynamicViewFTI>=0:${PORTSDIR}/devel/py-Products.CMFDynamicViewFTI \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFEditions>=1.2.2:${PORTSDIR}/devel/py-Products.CMFEditions
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+#USE_ZOPE= yes
+
+.include <bsd.port.mk>