aboutsummaryrefslogtreecommitdiff
path: root/www/py-requestbuilder/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-07-09 04:41:40 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-07-09 04:41:40 +0000
commit769445f1f03f0ec159769c0af46e94b9c88be718 (patch)
treee256c08fd1afdba1bddd3b82b050d17e8622e007 /www/py-requestbuilder/Makefile
parent2926c4246ba4f64488ff3a80ca2e354e7e45e044 (diff)
[NEW] www/py-requestbuilder: Command line-driven HTTP request builder
Command line-driven HTTP request builder. WWW: https://github.com/boto/requestbuilder
Notes
Notes: svn path=/head/; revision=361330
Diffstat (limited to 'www/py-requestbuilder/Makefile')
-rw-r--r--www/py-requestbuilder/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/py-requestbuilder/Makefile b/www/py-requestbuilder/Makefile
new file mode 100644
index 000000000000..f77644ea558c
--- /dev/null
+++ b/www/py-requestbuilder/Makefile
@@ -0,0 +1,22 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= requestbuilder
+PORTVERSION= 0.2.1
+CATEGORIES= www devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Command line-driven HTTP request builder
+
+LICENSE= ISCL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>