aboutsummaryrefslogtreecommitdiff
path: root/www/qt4-webkit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
commitd56984b0567867dd57ecb27fe0c508025c2426c5 (patch)
treeeb02dac4e0d7e5129ffac4c76b935a76a7e66676 /www/qt4-webkit
parent98813eadd27b8cd8500044af2a49b6d861809815 (diff)
downloadports-d56984b0567867dd57ecb27fe0c508025c2426c5.tar.gz
ports-d56984b0567867dd57ecb27fe0c508025c2426c5.zip
Notes
Diffstat (limited to 'www/qt4-webkit')
-rw-r--r--www/qt4-webkit/Makefile61
-rw-r--r--www/qt4-webkit/distinfo3
-rw-r--r--www/qt4-webkit/pkg-descr12
-rw-r--r--www/qt4-webkit/pkg-plist38
4 files changed, 114 insertions, 0 deletions
diff --git a/www/qt4-webkit/Makefile b/www/qt4-webkit/Makefile
new file mode 100644
index 000000000000..1e8ac98dcb48
--- /dev/null
+++ b/www/qt4-webkit/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: qt4-webkit
+# Date created: Mon May 12 17:18:19 CEST 2008
+# Whom: danny@ricin.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= webkit
+PORTVERSION= ${QT4_VERSION}
+CATEGORIES?= www
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt4 webkit engine
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build corelib gui network xml
+QT_NONSTANDARD= yes
+QT_DIST= yes
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= ${PREFIX}/lib/qt4
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/dbus src/opengl src/phonon \
+ src/qt3support src/script src/sql src/svg src/testlib \
+ src/tools src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/kdebase src/3rdparty/kdelibs
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/3rdparty/${PORTNAME}/WebCore
+CONFIGURE_WRKSRC=${WRKSRC}/../../../../
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${MKDIR} ${WRKSRC}/../../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../../bin/rcc
+
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e 's|.*$$(QMAKE).*||g' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ ${WRKSRC}/../../../../lib/pkgconfig/QtWebKit.pc
+
+.include <bsd.port.mk>
diff --git a/www/qt4-webkit/distinfo b/www/qt4-webkit/distinfo
new file mode 100644
index 000000000000..0c630f09baf6
--- /dev/null
+++ b/www/qt4-webkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/www/qt4-webkit/pkg-descr b/www/qt4-webkit/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/www/qt4-webkit/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/www/qt4-webkit/pkg-plist b/www/qt4-webkit/pkg-plist
new file mode 100644
index 000000000000..b0e49e7d34ef
--- /dev/null
+++ b/www/qt4-webkit/pkg-plist
@@ -0,0 +1,38 @@
+include/qt4/Qt/qwebframe.h
+include/qt4/Qt/qwebhistory.h
+include/qt4/Qt/qwebhistoryinterface.h
+include/qt4/Qt/qwebkitglobal.h
+include/qt4/Qt/qwebpage.h
+include/qt4/Qt/qwebpluginfactory.h
+include/qt4/Qt/qwebsettings.h
+include/qt4/Qt/qwebview.h
+include/qt4/Qt/QtWebKit
+include/qt4/QtWebKit/QWebFrame
+include/qt4/QtWebKit/QWebHistory
+include/qt4/QtWebKit/QWebHistoryInterface
+include/qt4/QtWebKit/QWebHistoryItem
+include/qt4/QtWebKit/QWebHitTestResult
+include/qt4/QtWebKit/QWebPage
+include/qt4/QtWebKit/QWebPluginFactory
+include/qt4/QtWebKit/QWebSettings
+include/qt4/QtWebKit/QWebView
+include/qt4/QtWebKit/QtWebKit
+include/qt4/QtWebKit/qwebframe.h
+include/qt4/QtWebKit/qwebhistory.h
+include/qt4/QtWebKit/qwebhistoryinterface.h
+include/qt4/QtWebKit/qwebkitglobal.h
+include/qt4/QtWebKit/qwebpage.h
+include/qt4/QtWebKit/qwebpluginfactory.h
+include/qt4/QtWebKit/qwebsettings.h
+include/qt4/QtWebKit/qwebview.h
+lib/qt4/libQtWebKit.la
+lib/qt4/libQtWebKit.prl
+lib/qt4/libQtWebKit.so
+lib/qt4/libQtWebKit.so.4
+lib/qt4/libQtWebKit.so.4.4
+lib/qt4/libQtWebKit.so.4.4.1
+%%DEBUG%%lib/qt4/libQtWebKit.so.4.4.1.debug
+libdata/pkgconfig/QtWebKit.pc
+@dirrm include/qt4/QtWebKit
+@dirrmtry include/qt4/Qt
+@dirrmtry include/qt4