aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webengine
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
commit93eea426e87f4ad07ba7751dea5dbff00744b015 (patch)
treea930492ad4894bbd691e092a984bbf3558e1feb8 /www/qt5-webengine
parentcf769d83efdb558f7179371d422b9a4f723b9697 (diff)
downloadports-93eea426e87f4ad07ba7751dea5dbff00744b015.tar.gz
ports-93eea426e87f4ad07ba7751dea5dbff00744b015.zip
misc/qtchooser: do not create unnecessary wrappers
misc/qtchooser provides a wrapper binary bin/qtchooser, that when called with name foo, will lauch the corresponding binary from lib/qt${current_qt_version}/bin/foo. Previously qtchooser would install a list of 30-ish symlinks to itself automatically. Now we switch this around. qt-dist ports that define QT_BINARIES will now have a @postexec and @postunexec entry added to their plist to run the shell-script update-qtchooser-wrapper (installed by qtchooser). update-qtchooser-wrapper removes all symlinks to bin/qtcreator that have no corresponding binary in lib/qt*/bin, and readds links that are missing. Exp-run by: antoine PR: 242905 PR: 243443 Reported by: grarpamp@gmail.com Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D22991
Notes
Notes: svn path=/head/; revision=524129
Diffstat (limited to 'www/qt5-webengine')
-rw-r--r--www/qt5-webengine/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 4d7eab7cba0e..2aa9f41d6801 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -18,7 +18,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -111,6 +111,8 @@ MAKE_ENV+= CC="${CC}" CXX="${CXX}" \
CPLUS_INCLUDE_PATH=${LOCALBASE}/include \
${CONFIGURE_ENV}
+QT_BINARIES= yes
+
.include <bsd.port.pre.mk>
.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64