aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webkit
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-10-03 20:35:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-10-03 20:35:29 +0000
commit4bbb4133b2730df60a15c7e7fb495841ffdb32c4 (patch)
treeb325616b604b3f18f851e5b3104e0289676790a9 /www/qt5-webkit
parent947645f5a712ad72340b44481d1d177bfd777110 (diff)
downloadports-4bbb4133b2730df60a15c7e7fb495841ffdb32c4.tar.gz
ports-4bbb4133b2730df60a15c7e7fb495841ffdb32c4.zip
devel/icu: update to 65.1
Notes
Notes: svn path=/head/; revision=513733
Diffstat (limited to 'www/qt5-webkit')
-rw-r--r--www/qt5-webkit/Makefile2
-rw-r--r--www/qt5-webkit/files/patch-Source_WebCore_dom_Document.cpp42
2 files changed, 43 insertions, 1 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index 1d5ee66812d4..eb38c2dad096 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -2,7 +2,7 @@
PORTNAME= webkit
DISTVERSION= 5.212.0-alpha3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= https://github.com/qt${PORTNAME}/qt${PORTNAME}/releases/download/${DISTNAME}/
PKGNAMEPREFIX= qt5-
diff --git a/www/qt5-webkit/files/patch-Source_WebCore_dom_Document.cpp b/www/qt5-webkit/files/patch-Source_WebCore_dom_Document.cpp
new file mode 100644
index 000000000000..d033a0e1bf49
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_WebCore_dom_Document.cpp
@@ -0,0 +1,42 @@
+Regressed by https://github.com/unicode-org/icu/commit/480bec3ea652
+
+In file included from Source/WebCore/dom/DOMAllInOne.cpp:67:
+Source/WebCore/dom/Document.cpp:4410:39: error: expected ';' after do/while statement
+ U16_NEXT(characters, i, length, c)
+ ^
+ ;
+Source/WebCore/dom/Document.cpp:4415:43: error: expected ';' after do/while statement
+ U16_NEXT(characters, i, length, c)
+ ^
+ ;
+Source/WebCore/dom/Document.cpp:4477:46: error: expected ';' after do/while statement
+ U16_NEXT(qualifiedName, i, length, c)
+ ^
+ ;
+
+--- Source/WebCore/dom/Document.cpp.orig 2019-06-26 16:25:02 UTC
++++ Source/WebCore/dom/Document.cpp
+@@ -4407,12 +4407,12 @@ static bool isValidNameNonASCII(const UChar* character
+ unsigned i = 0;
+
+ UChar32 c;
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNameStart(c))
+ return false;
+
+ while (i < length) {
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNamePart(c))
+ return false;
+ }
+@@ -4474,7 +4474,7 @@ bool Document::parseQualifiedName(const String& qualif
+
+ for (unsigned i = 0; i < length;) {
+ UChar32 c;
+- U16_NEXT(qualifiedName, i, length, c)
++ U16_NEXT(qualifiedName, i, length, c);
+ if (c == ':') {
+ if (sawColon) {
+ ec = NAMESPACE_ERR;