aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webkit
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-11-14 19:31:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-11-14 19:31:22 +0000
commitc932970c0f722f2066711f22d227b3d28f59f5e7 (patch)
treecaa432ae6d0cd54b4cc1dc65ffc36eb4e38eb3ba /www/qt5-webkit
parentdac13bb91c81a91a419c8bd6e1f93ac878c42102 (diff)
downloadports-c932970c0f722f2066711f22d227b3d28f59f5e7.tar.gz
ports-c932970c0f722f2066711f22d227b3d28f59f5e7.zip
www/qt5-webkit add upstream patch to disable broken ES6 proxy support
PR: 223668 Submitted by: Mikhail T. <mi@ALDAN.algebra.com>
Notes
Notes: svn path=/head/; revision=454197
Diffstat (limited to 'www/qt5-webkit')
-rw-r--r--www/qt5-webkit/Makefile2
-rw-r--r--www/qt5-webkit/files/patch-git_564844618
2 files changed, 19 insertions, 1 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index 8359944290f0..00de5b331139 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -2,7 +2,7 @@
PORTNAME= webkit
DISTVERSION= 5.212.0-alpha2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= https://github.com/annulen/${PORTNAME}/releases/download/${DISTNAME}/
PKGNAMEPREFIX= qt5-
diff --git a/www/qt5-webkit/files/patch-git_5648446 b/www/qt5-webkit/files/patch-git_5648446
new file mode 100644
index 000000000000..c408ec10a103
--- /dev/null
+++ b/www/qt5-webkit/files/patch-git_5648446
@@ -0,0 +1,18 @@
+Disable ES6 Proxy object
+
+https://github.com/annulen/webkit/commit/5648446933f52fe479d0a9006f6393a81a790116
+https://github.com/raelgc/scudcloud/issues/594#issuecomment-342988247
+
+--- Source/JavaScriptCore/runtime/JSGlobalObject.cpp
++++ Source/JavaScriptCore/runtime/JSGlobalObject.cpp
+@@ -458,7 +458,10 @@ m_ ## lowerName ## Prototype->putDirectWithoutTransition(vm, vm.propertyNames->c
+ putDirectWithoutTransition(vm, vm.propertyNames->TypeError, m_typeErrorConstructor.get(), DontEnum);
+ putDirectWithoutTransition(vm, vm.propertyNames->URIError, m_URIErrorConstructor.get(), DontEnum);
+
++#if !PLATFORM(QT)
++ // Disable ES6 Proxy because our implementation is not compliant with what real world code expects
+ putDirectWithoutTransition(vm, vm.propertyNames->Proxy, ProxyConstructor::create(vm, ProxyConstructor::createStructure(vm, this, m_functionPrototype.get())), DontEnum);
++#endif
+
+
+ #define PUT_CONSTRUCTOR_FOR_SIMPLE_TYPE(capitalName, lowerName, properName, instanceType, jsName) \