aboutsummaryrefslogtreecommitdiff
path: root/www/resin3/Makefile
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-04-11 18:04:38 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-04-11 18:04:38 +0000
commitb58430ef62fdeedc857cd0f11da170849208a590 (patch)
tree0fa2251f06e165794927d0bd8d8fb57cc46b7ce1 /www/resin3/Makefile
parent5ef802661615ad65f468e71c5b1071af26b8bf68 (diff)
downloadports-b58430ef62fdeedc857cd0f11da170849208a590.tar.gz
ports-b58430ef62fdeedc857cd0f11da170849208a590.zip
Notes
Diffstat (limited to 'www/resin3/Makefile')
-rw-r--r--www/resin3/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 62afcd9e765b..a18eb3ee25ee 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -18,6 +18,7 @@ JAVA_VERSION= 1.2+
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
+USE_AUTOTOOLS= libtool:15
# Customizable settings
RUNASUSER?= www
@@ -61,7 +62,7 @@ CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME} \
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
# We need to link with cc instead of ld for the FreeBSD specific options used
# by threading libraries
-CONFIGURE_ENV= LD=${CC} PTHREAD_LIBS=${PTHREAD_LIBS} LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LD=${CC} PTHREAD_LIBS=${PTHREAD_LIBS} LDFLAGS="${LDFLAGS}" LIBTOOL=${LIBTOOL}
# Install the Apache plugin if needed
.if defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES)
@@ -131,7 +132,7 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
.endif
post-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} install
+ cd ${WRKSRC}/modules/c/src/resin_os && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} install
# Resin does not handle installation, so proceed now
do-install: