aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-http
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-23 17:46:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-23 17:46:20 +0000
commit42810ec8a9be5bb5d729e87ac3a2421f54f95af9 (patch)
tree5cb8e96d644c2b9a028c9145893b463c0e6cccb4 /www/rubygem-http
parent9a38fccfcbadb2833da1fa46287de973506e98cd (diff)
downloadports-42810ec8a9be5bb5d729e87ac3a2421f54f95af9.tar.gz
ports-42810ec8a9be5bb5d729e87ac3a2421f54f95af9.zip
Update to 4.2.0
- Update version requirement of RUN_DEPENDS Changes: https://github.com/httprb/http/blob/master/CHANGES.md
Notes
Notes: svn path=/head/; revision=515296
Diffstat (limited to 'www/rubygem-http')
-rw-r--r--www/rubygem-http/Makefile10
-rw-r--r--www/rubygem-http/distinfo6
-rw-r--r--www/rubygem-http/pkg-descr2
3 files changed, 9 insertions, 9 deletions
diff --git a/www/rubygem-http/Makefile b/www/rubygem-http/Makefile
index 7e24b3f2874e..1e4185b5e0c4 100644
--- a/www/rubygem-http/Makefile
+++ b/www/rubygem-http/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= http
-PORTVERSION= 4.1.1
+PORTVERSION= 4.2.0
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -12,10 +12,10 @@ COMMENT= Simple Ruby DSL for making HTTP requests
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= rubygem-addressable>=2.3:www/rubygem-addressable \
- rubygem-http-cookie>=1.0:www/rubygem-http-cookie \
- rubygem-http-form_data>=2.0:www/rubygem-http-form_data \
- rubygem-http_parser.rb>=0.6.0:net/rubygem-http_parser.rb
+RUN_DEPENDS= rubygem-addressable>=2.3<3:www/rubygem-addressable \
+ rubygem-http-cookie>=1.0<2:www/rubygem-http-cookie \
+ rubygem-http-form_data>=2.0<3:www/rubygem-http-form_data \
+ rubygem-http-parser>=1.2.0<1.3:net/rubygem-http-parser
USES= gem
USE_RUBY= yes
diff --git a/www/rubygem-http/distinfo b/www/rubygem-http/distinfo
index 0b7047a33ef7..cdd4d88bfe73 100644
--- a/www/rubygem-http/distinfo
+++ b/www/rubygem-http/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563013441
-SHA256 (rubygem/http-4.1.1.gem) = fae822948ac22a99caff02276e3db6934d4ecb2f38f90b3596820cadc6e23c80
-SIZE (rubygem/http-4.1.1.gem) = 74240
+TIMESTAMP = 1571843591
+SHA256 (rubygem/http-4.2.0.gem) = 94cba7e59d19fc5e81ba26b7928173ba516bb0f5eb8e7d03df8a9d98ab0456bf
+SIZE (rubygem/http-4.2.0.gem) = 74752
diff --git a/www/rubygem-http/pkg-descr b/www/rubygem-http/pkg-descr
index e40347d24567..d1c18c447537 100644
--- a/www/rubygem-http/pkg-descr
+++ b/www/rubygem-http/pkg-descr
@@ -1,6 +1,6 @@
The HTTP Gem is an easy-to-use client library for making requests from Ruby. It
uses a simple method chaining system for building requests, similar to Python's
-Requests
+Requests.
Under the hood, The HTTP Gem uses http_parser.rb, a fast HTTP parsing native
extension based on the Node.js parser and a Java port thereof.