aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-maruku/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-26 19:38:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-26 19:38:48 +0000
commitf3471ec16f5f544a1c3dd75e508fae07466822c7 (patch)
treeb6f27c240bcbba632f3a5df40e3ce9872f35b067 /www/rubygem-maruku/Makefile
parent0d840ed535e91082dc912d8eb3ccde08f0197dc1 (diff)
Notes
Diffstat (limited to 'www/rubygem-maruku/Makefile')
-rw-r--r--www/rubygem-maruku/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/rubygem-maruku/Makefile b/www/rubygem-maruku/Makefile
new file mode 100644
index 000000000000..95aca4ac282d
--- /dev/null
+++ b/www/rubygem-maruku/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: rubygem-maruku
+# Date created: 26 April 2007
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+
+PORTNAME= maruku
+PORTVERSION= 0.5.5
+CATEGORIES= www rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A Markdown and PHP Markdown extra interpreter for Ruby
+
+BUILD_DEPENDS= rubygem-syntax>=1.0.0:${PORTSDIR}/textproc/rubygem-syntax
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+USE_RUBY_FEATURES= iconv
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>