aboutsummaryrefslogtreecommitdiff
path: root/www/screem-devel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-15 08:56:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-15 08:56:38 +0000
commit9a95a1cae31cb5d68407f94c19a14953408ef192 (patch)
treebbf046bf0aba88d0ab8d6ba2211e27b632c8ca8b /www/screem-devel/Makefile
parentac483822462c1742036d14efc579a1e7cc40d109 (diff)
Update to 0.5.5 which makes screem a GNOME 2 app. Yay!
PR: 45302 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=70155
Diffstat (limited to 'www/screem-devel/Makefile')
-rw-r--r--www/screem-devel/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index 994b73b8d87e..f3836d0a7f2c 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -6,27 +6,31 @@
#
PORTNAME= screem
-PORTVERSION= 0.4.1
-PORTREVISION= 3
+PORTVERSION= 0.5.5
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.screem.org/src/ \
- http://www.borgsdemons.com/distfiles/screem/
+ http://www.screem.org/src/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-docs${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= coop9211@uidaho.edu
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui \
+ gtkhtml-2.0:${PORTSDIR}/www/libgtkhtml \
+ zvt-2.0.0:${PORTSDIR}/x11-toolkits/libzvt \
+ neon.22:${PORTSDIR}/www/neon
+
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomevfs gtkhtml
+USE_GNOME= gnomeprefix gnomehack
USE_LIBTOOL= yes
USE_OPENSSL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/gnome-vfs-1.0" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gnomevfs --with-ssl --with-included-neon
+CONFIGURE_ARGS= --with-gnomevfs --with-ssl
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@@ -34,8 +38,4 @@ post-patch:
@find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
's|\@GNOME_DATA_PREFIX\@|\$$\(datadir\)|g'
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/../${PORTNAME}-docs/* \
- ${PREFIX}/share/gnome/help/screem/C/
-
.include <bsd.port.mk>