aboutsummaryrefslogtreecommitdiff
path: root/www/screem/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /www/screem/Makefile
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'www/screem/Makefile')
-rw-r--r--www/screem/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/www/screem/Makefile b/www/screem/Makefile
index 6a2989c2e2ee..c6b03ef99d67 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= screem
-PORTVERSION= 0.10.2
-CATEGORIES= www editors gnome
+PORTVERSION= 0.12.0
+CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +15,22 @@ MAINTAINER= coop9211@uidaho.edu
COMMENT= Nice GNOME/GTK-based HTML editor
LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon \
- croco.3:${PORTSDIR}/textproc/libcroco
+ croco-${CROCO_VERSION}.3:${PORTSDIR}/textproc/libcroco \
+ dbus-1.0:${PORTSDIR}/devel/dbus
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
- gtksourceview lthack intlhack
-USE_INC_LIBTOOL_VER=13
-INSTALLS_SHLIB= yes
+ gtksourceview intlhack
+USE_LIBTOOL_VER=15
-.ifndef WITHOUT_OPENSSL
+GCONF_SCHEMAS= screem.schemas
+
+CROCO_VERSION= 0.6
+
+.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl
.endif
@@ -39,8 +43,17 @@ CONFIGURE_ARGS+= --without-included-neon
post-patch:
@${REINPLACE_CMD} -e 's|\$${DATADIRNAME}/\$${PACKAGE}/pixmaps|\$${DATADIRNAME}/gnome/\$${PACKAGE}/pixmaps|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(datadir)/mime/|${PREFIX}/share/mime/| ; \
+ s|$$(datadir)/mime$$|${PREFIX}/share/mime|' \
+ ${WRKSRC}/data/mime/Makefile.in \
+ ${WRKSRC}/data/tagtrees/Makefile.in
post-configure:
@${REINPLACE_CMD} -e 's|\/\* #undef HAVE_LIMITS_H \*\/|#define HAVE_LIMITS_H 1|g' ${WRKSRC}/config.h
+# HACK: This allows test builds into a temporary directory, but in the REAL world,
+# gconf would have created this directory.
+pre-install:
+ @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults
+
.include <bsd.port.mk>