aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-21 16:41:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-21 16:41:54 +0000
commitde3a2c4ba372c1b208faa0510eb27414d5d741c6 (patch)
tree3da19210e5e1dcb15e35ace6c61cbed3441568ef /www/seamonkey2/Makefile
parent2e3c7b8192224bc78804d6b5d021bff8a8934f2a (diff)
downloadports-de3a2c4ba372c1b208faa0510eb27414d5d741c6.tar.gz
ports-de3a2c4ba372c1b208faa0510eb27414d5d741c6.zip
Notes
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 48cc223aeaf7..96af179694eb 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.2b
-PORTREVISION?= 3
+PORTVERSION= 1.3a
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- http://people.FreeBSD.org/~marcus/:local
+ ${MASTER_SITE_LOCAL}:local
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
marcus/:local
DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
@@ -72,11 +72,8 @@ CONFIGURE_ARGS= \
--enable-crypto \
--disable-debug \
--enable-double-buffer \
- --enable-dtd-debug \
- --enable-jsd \
--enable-mathml \
--disable-md \
- --disable-optimize \
--disable-pedantic \
--disable-plaintext-editor-only \
--enable-strip \
@@ -114,6 +111,11 @@ CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+.if defined(WITH_JAVASCRIPT_DEBUGGER)
+CONFIGURE_ARGS+= --enable-jsd \
+ --enable-dtd-debug
+.endif
+
.if defined(WITH_CALENDAR)
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --enable-calendar
@@ -125,7 +127,6 @@ CONFIGURE_ARGS+= --disable-composer
.if defined(WITH_GTK2)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-EXTRA_PATCHES= ${FILESDIR}/mozilla_12b_patch
PKGCONFIG_FILES= mozilla-gtkmozembed.pc mozilla-js.pc mozilla-xpcom.pc \
mozilla-nspr.pc mozilla-nss.pc
.else