aboutsummaryrefslogtreecommitdiff
path: root/www/shttpd
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-15 17:18:15 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-15 17:18:15 +0000
commit5336b186be8191015c0d3a58e9dfeffe8c5f3510 (patch)
tree8eba65a5b13bf21d9cf5c224922b93259a862a7f /www/shttpd
parentb2f715d150f657fc7bfb8299eaa841d346f0f5bc (diff)
downloadports-5336b186be8191015c0d3a58e9dfeffe8c5f3510.tar.gz
ports-5336b186be8191015c0d3a58e9dfeffe8c5f3510.zip
Notes
Diffstat (limited to 'www/shttpd')
-rw-r--r--www/shttpd/Makefile36
-rw-r--r--www/shttpd/distinfo2
-rw-r--r--www/shttpd/files/shttpd.143
-rw-r--r--www/shttpd/pkg-descr10
4 files changed, 91 insertions, 0 deletions
diff --git a/www/shttpd/Makefile b/www/shttpd/Makefile
new file mode 100644
index 000000000000..5399a57039f9
--- /dev/null
+++ b/www/shttpd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: shttpd
+# Date created: Wed Dec 15, 2004
+# Whom: Sergey Lyubka (valenok@gmail.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= shttpd
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= shttpd
+DISTNAME= httpd.c
+EXTRACT_SUFX=
+EXTRACT_ONLY= #none
+
+MAINTAINER= valenok@gmail.com
+COMMENT= Simple embeddable web server with CGI support
+
+NO_WRKSUBDIR= yes
+DIST_SUBDIR= ${PORTNAME}
+MAN1= shttpd.1
+
+PLIST_FILES= bin/shttpd
+
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/httpd.c ${WRKSRC}/
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/shttpd ${WRKSRC}/httpd.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/shttpd ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/shttpd.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/www/shttpd/distinfo b/www/shttpd/distinfo
new file mode 100644
index 000000000000..388f7caec70f
--- /dev/null
+++ b/www/shttpd/distinfo
@@ -0,0 +1,2 @@
+MD5 (shttpd/httpd.c) = b889be47e050449250931c46ba40b525
+SIZE (shttpd/httpd.c) = 41033
diff --git a/www/shttpd/files/shttpd.1 b/www/shttpd/files/shttpd.1
new file mode 100644
index 000000000000..2c2ced3a6c6e
--- /dev/null
+++ b/www/shttpd/files/shttpd.1
@@ -0,0 +1,43 @@
+.TH SHTTPD 1
+.SH NAME
+shttpd \- Simple HTTP Daemon
+.SH SYNOPSIS
+.B shttpd
+.I [OPTIONS]
+.br
+.SH "DESCRIPTION"
+.B shttpd
+is a simple web server with CGI support.
+It does not detach from terminal. It stores logs in a standard format.
+.SH OPTIONS
+.TP 13
+.I \-d directory
+document root directory (default .)
+.TP 13
+.I \-p port
+listening port (default 80 for non-SSL, 443 for SSL mode)
+.TP 13
+.I \-h
+display help
+.TP 13
+.I \-l logfile
+log file (default httpd.log)
+.TP 13
+.I \-i file1[,file2..]
+index file (default index.html,index.cgi,index.php)
+.TP 13
+.I \-c
+CGI file pattern (default .cgi)
+.TP 13
+.I \-P passfile
+global auth passwords file (default none)
+.TP 13
+.I \-u uid
+run-time numeric UID (default none)
+.SH COPYRIGHT
+.B shttpd
+is licensed under the terms of MIT license.
+.SH BUGS
+Please send bug reports to <valenok@gmail.com>
+.SH AUTHOR
+Sergey Lyubka <valenok@gmail.com>
diff --git a/www/shttpd/pkg-descr b/www/shttpd/pkg-descr
new file mode 100644
index 000000000000..b9693333432c
--- /dev/null
+++ b/www/shttpd/pkg-descr
@@ -0,0 +1,10 @@
+SHTTPD is a simple, easy to use, embeddable web server with CGI,
+SSL, cookies support. It is written in C, as one single source file httpd.c,
+and compiles both in UNIX and Windows environments. Gives exceptionally
+small footprint when linked against uclibc or dietlibc. It is a good choice
+to serve Web based GUI for various applications, where other sophisticated
+servers like Apache, IIS etc are too big, hard to install and configure or
+overcomplicated.
+shttpd is licensed under the terms of very liberal MIT license.
+
+WWW: http://shttpd.sf.net