aboutsummaryrefslogtreecommitdiff
path: root/www/smarty
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-09 20:29:35 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-09 20:29:35 +0000
commitc5ecded283a20a51f6b00179d451043500180dbc (patch)
treefba85fea20246e05acff8f0f7d6d53b2309f782d /www/smarty
parentd3efda6ac08a3a89fa74bcc50d049c38b91b8196 (diff)
downloadports-c5ecded283a20a51f6b00179d451043500180dbc.tar.gz
ports-c5ecded283a20a51f6b00179d451043500180dbc.zip
Notes
Diffstat (limited to 'www/smarty')
-rw-r--r--www/smarty/Makefile57
-rw-r--r--www/smarty/distinfo2
-rw-r--r--www/smarty/files/pkg-message4
-rw-r--r--www/smarty/pkg-comment1
-rw-r--r--www/smarty/pkg-descr13
-rw-r--r--www/smarty/pkg-plist179
6 files changed, 256 insertions, 0 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
new file mode 100644
index 000000000000..47258cf132a6
--- /dev/null
+++ b/www/smarty/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: smarty
+# Date created: 10 March 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smarty
+PORTVERSION= 2.0
+CATEGORIES= www
+MASTER_SITES= http://www.phpinsider.com/php/code/Smarty/download/
+DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES+= Smarty-${PORTVERSION}-docs${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= corecode@corecode.ath.cx
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
+
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+MSG_SRC=${FILESDIR}/pkg-message
+
+MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php overlib.js
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/plugins/* ${DATADIR}/plugins
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in BUGS FAQ INSTALL QUICKSTART README RESOURCES
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ @${MKDIR} ${DOCSDIR}/manual
+ @${INSTALL_DATA} ${WRKDIR}/manual/* ${DOCSDIR}/manual
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/index.php ${EXAMPLESDIR}
+.for f in configs templates templates_c cache
+ @${MKDIR} ${EXAMPLESDIR}/$f
+ @-${INSTALL_DATA} ${WRKSRC}/$f/* ${EXAMPLESDIR}/$f 2>/dev/null || ${TRUE}
+.endfor
+.endif
+
+post-install:
+ @${SED} ${MSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${MSG_SRC} > \
+ ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/smarty/distinfo b/www/smarty/distinfo
new file mode 100644
index 000000000000..09d7102fc979
--- /dev/null
+++ b/www/smarty/distinfo
@@ -0,0 +1,2 @@
+MD5 (Smarty-2.0.tar.gz) = f708ab578e8ad1c16a3873d28fd09d03
+MD5 (Smarty-2.0-docs.tar.gz) = b724fda1abe43b6e560570da77a1ef82
diff --git a/www/smarty/files/pkg-message b/www/smarty/files/pkg-message
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/www/smarty/files/pkg-message
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/www/smarty/pkg-comment b/www/smarty/pkg-comment
new file mode 100644
index 000000000000..2d6120509808
--- /dev/null
+++ b/www/smarty/pkg-comment
@@ -0,0 +1 @@
+The PHP compiling template engine
diff --git a/www/smarty/pkg-descr b/www/smarty/pkg-descr
new file mode 100644
index 000000000000..fa3539b3df61
--- /dev/null
+++ b/www/smarty/pkg-descr
@@ -0,0 +1,13 @@
+Smarty is a template engine for PHP. Many other template engines for PHP
+provide basic variable substitution and dynamic block functionality.
+Smarty takes a step further to be a "smart" template engine, adding
+features such as configuration files, template functions, and variable
+modifiers, and making all of this functionality as easy as possible to
+use for both programmers and template designers. Smarty also converts
+the templates into PHP scripts, eliminating the need to parse the
+templates on every invocation. This makes Smarty extremely scalable and
+managable for large application needs.
+
+WWW: http://www.phpinsider.com/php/code/Smarty/
+
+- Simon 'corecode' Schubert
diff --git a/www/smarty/pkg-plist b/www/smarty/pkg-plist
new file mode 100644
index 000000000000..ea8771592b34
--- /dev/null
+++ b/www/smarty/pkg-plist
@@ -0,0 +1,179 @@
+%%PORTDOCS%%share/doc/smarty/BUGS
+%%PORTDOCS%%share/doc/smarty/FAQ
+%%PORTDOCS%%share/doc/smarty/INSTALL
+%%PORTDOCS%%share/doc/smarty/QUICKSTART
+%%PORTDOCS%%share/doc/smarty/README
+%%PORTDOCS%%share/doc/smarty/RESOURCES
+%%PORTDOCS%%share/doc/smarty/manual/advanced.features.html
+%%PORTDOCS%%share/doc/smarty/manual/advanced.features.postfilters.html
+%%PORTDOCS%%share/doc/smarty/manual/api.append.html
+%%PORTDOCS%%share/doc/smarty/manual/api.assign.html
+%%PORTDOCS%%share/doc/smarty/manual/api.clear.all.assign.html
+%%PORTDOCS%%share/doc/smarty/manual/api.clear.all.cache.html
+%%PORTDOCS%%share/doc/smarty/manual/api.clear.assign.html
+%%PORTDOCS%%share/doc/smarty/manual/api.clear.cache.html
+%%PORTDOCS%%share/doc/smarty/manual/api.clear.compiled.tpl.html
+%%PORTDOCS%%share/doc/smarty/manual/api.display.html
+%%PORTDOCS%%share/doc/smarty/manual/api.fetch.html
+%%PORTDOCS%%share/doc/smarty/manual/api.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/api.get.template.vars.html
+%%PORTDOCS%%share/doc/smarty/manual/api.html
+%%PORTDOCS%%share/doc/smarty/manual/api.is.cached.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.compiler.function.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.function.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.modifier.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.postfilter.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.prefilter.html
+%%PORTDOCS%%share/doc/smarty/manual/api.register.resource.html
+%%PORTDOCS%%share/doc/smarty/manual/api.trigger.error.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.compiler.function.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.function.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.modifier.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.postfilter.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.prefilter.html
+%%PORTDOCS%%share/doc/smarty/manual/api.unregister.resource.html
+%%PORTDOCS%%share/doc/smarty/manual/appendixes.html
+%%PORTDOCS%%share/doc/smarty/manual/bugs.html
+%%PORTDOCS%%share/doc/smarty/manual/chapter.debugging.console.html
+%%PORTDOCS%%share/doc/smarty/manual/config.files.html
+%%PORTDOCS%%share/doc/smarty/manual/constant.smarty.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/default.template.handler.function.html
+%%PORTDOCS%%share/doc/smarty/manual/features.caching.html
+%%PORTDOCS%%share/doc/smarty/manual/features.compiling.html
+%%PORTDOCS%%share/doc/smarty/manual/getting.started.html
+%%PORTDOCS%%share/doc/smarty/manual/how.smarty.works.html
+%%PORTDOCS%%share/doc/smarty/manual/index.html
+%%PORTDOCS%%share/doc/smarty/manual/installation.html
+%%PORTDOCS%%share/doc/smarty/manual/installing.smarty.html
+%%PORTDOCS%%share/doc/smarty/manual/language.assigned.variables.html
+%%PORTDOCS%%share/doc/smarty/manual/language.builtin.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/language.builtin.modifiers.html
+%%PORTDOCS%%share/doc/smarty/manual/language.combining.modifiers.html
+%%PORTDOCS%%share/doc/smarty/manual/language.config.variables.html
+%%PORTDOCS%%share/doc/smarty/manual/language.custom.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/language.custom.functions.top.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.capture.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.config.load.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.foreach.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.if.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.include.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.include.php.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.insert.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.ldelim.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.literal.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.php.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.section.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.strip.html
+%%PORTDOCS%%share/doc/smarty/manual/language.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifiers.html
+%%PORTDOCS%%share/doc/smarty/manual/language.syntax.attributes.html
+%%PORTDOCS%%share/doc/smarty/manual/language.syntax.comments.html
+%%PORTDOCS%%share/doc/smarty/manual/language.syntax.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/language.variables.html
+%%PORTDOCS%%share/doc/smarty/manual/language.variables.smarty.html
+%%PORTDOCS%%share/doc/smarty/manual/overview.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.compiler.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.functions.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.inserts.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.modifiers.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.naming.conventions.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.prefilters.postfilters.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.resources.html
+%%PORTDOCS%%share/doc/smarty/manual/plugins.writing.html
+%%PORTDOCS%%share/doc/smarty/manual/preface.html
+%%PORTDOCS%%share/doc/smarty/manual/resources.html
+%%PORTDOCS%%share/doc/smarty/manual/section.template.cache.handler.func.html
+%%PORTDOCS%%share/doc/smarty/manual/smarty.constants.html
+%%PORTDOCS%%share/doc/smarty/manual/smarty.for.designers.html
+%%PORTDOCS%%share/doc/smarty/manual/smarty.for.programmersr.html
+%%PORTDOCS%%share/doc/smarty/manual/template.resources.html
+%%PORTDOCS%%share/doc/smarty/manual/templates.from.any.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/templates.from.elsewhere.html
+%%PORTDOCS%%share/doc/smarty/manual/templates.from.template.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.componentized.templates.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.dates.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.default.var.handling.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.obfuscating.email.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.passing.vars.html
+%%PORTDOCS%%share/doc/smarty/manual/tips.wap.html
+%%PORTDOCS%%share/doc/smarty/manual/troubleshooting.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.cache.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.cache.handler.func.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.cache.lifetime.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.cache.modified.check.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.caching.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.compile.check.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.compile.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.compile.id.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.compiler.class.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.config.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.debug.tpl.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.debugging.ctrl.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.debugging.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.default.template.handler.func.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.force.compile.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.global.assign.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.left.delimiter.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.php.handling.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.plugins.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.request.vars.order.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.right.delimiter.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.secure.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.security.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.security.settings.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.show.info.header.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.show.info.include.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.template.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.trusted.dir.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.undefined.html
+%%PORTDOCS%%share/examples/smarty/configs/test.conf
+%%PORTDOCS%%share/examples/smarty/index.php
+%%PORTDOCS%%share/examples/smarty/templates/debug.tpl
+%%PORTDOCS%%share/examples/smarty/templates/footer.tpl
+%%PORTDOCS%%share/examples/smarty/templates/header.tpl
+%%PORTDOCS%%share/examples/smarty/templates/index.tpl
+%%PORTDOCS%%@exec mkdir -p %D/share/examples/smarty/templates_c
+%%PORTDOCS%%@exec mkdir -p %D/share/examples/smarty/cache
+share/smarty/Config_File.class.php
+share/smarty/Smarty.class.php
+share/smarty/Smarty_Compiler.class.php
+share/smarty/overlib.js
+share/smarty/plugins/function.assign.php
+share/smarty/plugins/function.assign_debug_info.php
+share/smarty/plugins/function.counter.php
+share/smarty/plugins/function.eval.php
+share/smarty/plugins/function.fetch.php
+share/smarty/plugins/function.html_options.php
+share/smarty/plugins/function.html_select_date.php
+share/smarty/plugins/function.html_select_time.php
+share/smarty/plugins/function.math.php
+share/smarty/plugins/function.popup.php
+share/smarty/plugins/function.popup_init.php
+share/smarty/plugins/modifier.capitalize.php
+share/smarty/plugins/modifier.count_characters.php
+share/smarty/plugins/modifier.count_paragraphs.php
+share/smarty/plugins/modifier.count_sentences.php
+share/smarty/plugins/modifier.count_words.php
+share/smarty/plugins/modifier.date_format.php
+share/smarty/plugins/modifier.debug_print_var.php
+share/smarty/plugins/modifier.default.php
+share/smarty/plugins/modifier.escape.php
+share/smarty/plugins/modifier.lower.php
+share/smarty/plugins/modifier.regex_replace.php
+share/smarty/plugins/modifier.replace.php
+share/smarty/plugins/modifier.spacify.php
+share/smarty/plugins/modifier.string_format.php
+share/smarty/plugins/modifier.strip_tags.php
+share/smarty/plugins/modifier.truncate.php
+share/smarty/plugins/modifier.upper.php
+@dirrm share/smarty/plugins
+@dirrm share/smarty
+%%PORTDOCS%%@dirrm share/examples/smarty/templates_c
+%%PORTDOCS%%@dirrm share/examples/smarty/templates
+%%PORTDOCS%%@dirrm share/examples/smarty/configs
+%%PORTDOCS%%@dirrm share/examples/smarty/cache
+%%PORTDOCS%%@dirrm share/examples/smarty
+%%PORTDOCS%%@dirrm share/doc/smarty/manual
+%%PORTDOCS%%@dirrm share/doc/smarty