aboutsummaryrefslogtreecommitdiff
path: root/www/squid30
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-31 22:20:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-31 22:20:42 +0000
commit92531c1b9e19748331bd9a0cbc116e2e6cdbadd6 (patch)
tree1e76cb8ce774e1450aac8c670c3095c89ad8c493 /www/squid30
parentfd1a1ba16500bda2419bb0f643fe77ee3dcd9d30 (diff)
downloadports-92531c1b9e19748331bd9a0cbc116e2e6cdbadd6.tar.gz
ports-92531c1b9e19748331bd9a0cbc116e2e6cdbadd6.zip
Notes
Diffstat (limited to 'www/squid30')
-rw-r--r--www/squid30/Makefile1
-rw-r--r--www/squid30/files/patch-squid_kerb_auth22
2 files changed, 23 insertions, 0 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index a01c18a83aa7..0558907742a3 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,6 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid30/files/patch-squid_kerb_auth b/www/squid30/files/patch-squid_kerb_auth
index 359bc6f68ca2..371db4eaa383 100644
--- a/www/squid30/files/patch-squid_kerb_auth
+++ b/www/squid30/files/patch-squid_kerb_auth
@@ -466,3 +466,25 @@ ports framework where Heimdal is part of the base system.
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
#else
#include <gssapi/gssapi.h>
+--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2009-03-28 17:01:45.000000000 +0100
++++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:06:55.000000000 +0100
+@@ -22,12 +22,19 @@
+ //
+ /////////////////////////////////////////////////////////////
+
++#include "config.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include "spnego.h"
+ #include "derparse.h"
+
++#ifdef WORDS_BIGENDIAN
++#undef __LITTLE_ENDIAN__
++#else
++#define __LITTLE_ENDIAN__ 1
++#endif
++
+ //
+ // The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
+ // the array below, that a mechanism can be found.