aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2016-12-23 03:41:51 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2016-12-23 03:41:51 +0000
commit153512e0d8d7b5cd38a450303e6466b8509197bd (patch)
tree73242ba57761eb24ef1f2c10bfdb74721b51872f /www/squid
parent90ff83398e65d0c70531580f858ff3f50b1fedcb (diff)
downloadports-153512e0d8d7b5cd38a450303e6466b8509197bd.tar.gz
ports-153512e0d8d7b5cd38a450303e6466b8509197bd.zip
www/squid: update 3.5.22 -> 3.5.23
- Spell CHOSEN_COMPILER_TYPE correctly - Remove upstreamed patch (IPv6 + PF crash) - Add --enable-zph-qos option to default set http://wiki.squid-cache.org/Features/QualityOfService PR: 215416 Submitted by: Pavel Timofeev <timp87@gmail.com> (maintainer) Security: CVE-2016-10002 Security: CVE-2016-10003 Security: https://vuxml.FreeBSD.org/freebsd/41f8af15-c8b9-11e6-ae1b-002590263bf5.html MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=429217
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile8
-rw-r--r--www/squid/distinfo4
-rw-r--r--www/squid/files/patch-src__ip__Intercept.cc38
3 files changed, 6 insertions, 44 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 50ca7565353a..92fbacbdbfec 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= squid
-PORTVERSION= 3.5.22
+PORTVERSION= 3.5.23
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
@@ -222,6 +222,7 @@ CONFIGURE_ARGS= --with-default-user=squid \
--with-swapdir=/var/squid/cache \
--without-gnutls \
--enable-auth \
+ --enable-zph-qos \
--enable-build-info \
--enable-loadable-modules \
--enable-removal-policies="lru heap" \
@@ -316,11 +317,10 @@ post-install:
BROKEN= Does not build with openssl-devel
.endif
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
#CXXFLAGS+= -Wno-unused-private-field
-.if ${COMPILER_VERSION} >= 35
+CXXFLAGS+= -Wno-unknown-warning-option
CXXFLAGS+= -Wno-undefined-bool-conversion -Wno-tautological-undefined-compare -Wno-dynamic-class-memaccess
.endif
-.endif
.include <bsd.port.post.mk>
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 238615df191f..6b87b3bbb3ae 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1479930399
-SHA256 (squid3.5/squid-3.5.22.tar.xz) = 1ce95b469257abeb2ed8a1c0417812301c1ef5a4cc40ca504167daa470ad9358
-SIZE (squid3.5/squid-3.5.22.tar.xz) = 2324164
+SHA256 (squid3.5/squid-3.5.23.tar.xz) = fa4c0c99f41e92fe1330bed3968d176c6f47ef2e3aea2f83977d5501afa40bdb
+SIZE (squid3.5/squid-3.5.23.tar.xz) = 2325884
diff --git a/www/squid/files/patch-src__ip__Intercept.cc b/www/squid/files/patch-src__ip__Intercept.cc
index 7bb4250b30d0..1648e1837415 100644
--- a/www/squid/files/patch-src__ip__Intercept.cc
+++ b/www/squid/files/patch-src__ip__Intercept.cc
@@ -13,41 +13,3 @@
return false;
#else
natLookup.nl_v = 6;
-@@ -323,13 +323,21 @@
- }
-
- memset(&nl, 0, sizeof(struct pfioc_natlook));
-- newConn->remote.getInAddr(nl.saddr.v4);
-+ if (newConn->remote.isIPv4()) {
-+ newConn->remote.getInAddr(nl.saddr.v4);
-+ } else {
-+ newConn->remote.getInAddr(nl.saddr.v6);
-+ }
- nl.sport = htons(newConn->remote.port());
-
-- newConn->local.getInAddr(nl.daddr.v4);
-+ if (newConn->local.isIPv4()) {
-+ newConn->local.getInAddr(nl.daddr.v4);
-+ } else {
-+ newConn->local.getInAddr(nl.daddr.v6);
-+ }
- nl.dport = htons(newConn->local.port());
-
-- nl.af = AF_INET;
-+ nl.af = newConn->remote.isIPv4() ? AF_INET : AF_INET6;
- nl.proto = IPPROTO_TCP;
- nl.direction = PF_OUT;
-
-@@ -345,7 +353,11 @@
- debugs(89, 9, HERE << "address: " << newConn);
- return false;
- } else {
-- newConn->local = nl.rdaddr.v4;
-+ if (nl.af == AF_INET) {
-+ newConn->local = nl.rdaddr.v4;
-+ } else {
-+ newConn->local = nl.rdaddr.v6;
-+ }
- newConn->local.port(ntohs(nl.rdport));
- debugs(89, 5, HERE << "address NAT: " << newConn);
- return true;