aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 19:10:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 19:10:40 +0000
commit3dc217b8c88267b32dea2eeecc4c38261ea89108 (patch)
treed6bd57c72f52765607fb28d5814c427a1cae76c4 /www/squid
parentce65e110773be7e62301988531237f5beaa413df (diff)
downloadports-3dc217b8c88267b32dea2eeecc4c38261ea89108.tar.gz
ports-3dc217b8c88267b32dea2eeecc4c38261ea89108.zip
www/squid: fix build with GCC-based architectures
Add -Wno-error=stringop-truncation to CFLAGS when using GCC. PR: 237276 Approved by: timp87@gmail.com (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20104
Notes
Notes: svn path=/head/; revision=500555
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6a7eb33283c4..538b419160c8 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -25,8 +25,6 @@ COMMENT= HTTP Caching Proxy
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to link: ext_time_quota_acl.cc: undefined reference to std::ctype
-
USES= compiler:c++11-lib cpe perl5 shebangfix tar:xz
CONFLICTS= squid*-3.*
@@ -191,6 +189,9 @@ VIA_DB_DESC= Forward/Via database
WCCPV2_DESC= Web Cache Coordination Protocol v2
WCCP_DESC= Web Cache Coordination Protocol
+CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
+CFLAGS_gcc= -Wno-error=stringop-truncation
+
change_files= ChangeLog \
contrib/nextstep/makepkg \
contrib/nextstep/post_install \