aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-04-22 12:29:44 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-04-22 12:29:44 +0000
commit6d0d4c3320ac3c30035eac5dab1e5eb64c9dbb4b (patch)
treeb2daa7fb3abb62bcbd7633d81b38c56acee16258 /www/squid
parenta03d0cd8179c6c741bb74e03d4b26203f1194d54 (diff)
downloadports-6d0d4c3320ac3c30035eac5dab1e5eb64c9dbb4b.tar.gz
ports-6d0d4c3320ac3c30035eac5dab1e5eb64c9dbb4b.zip
www/squid: Fix build with GSSAPI options
In some circumstances squid's configure script cannot detect properly which GSSAPI is being used to build with and break build. Applied patch from upstream ticket and also passes path of desired krb5-config to be used during build PR: 236959 Approved by: maintainer timeout (2 weeks) Obtained from: https://bugs.squid-cache.org/show_bug.cgi?id=4933 (based on) Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=499632
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile13
-rw-r--r--www/squid/files/patch-configure40
2 files changed, 39 insertions, 14 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6f11255fb108..6a7eb33283c4 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -2,6 +2,7 @@
PORTNAME= squid
PORTVERSION= 4.6
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v4/ \
http://www2.us.squid-cache.org/Versions/v4/ \
@@ -137,15 +138,21 @@ GSSAPI_NONE_CONFIGURE_ON= --without-heimdal-krb5 \
--without-gss
GSSAPI_BASE_USES= gssapi
-GSSAPI_BASE_CONFIGURE_ON= --with-heimdal-krb5=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_BASE_CONFIGURE_ON= --with-heimdal-krb5=${GSSAPIBASEDIR} \
+ ${GSSAPI_CONFIGURE_ARGS} \
+ krb5_config=${GSSAPIBASEDIR}/bin/krb5-config
GSSAPI_BASE_PLIST_SUB= AUTH_KERB=""
GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_HEIMDAL_CONFIGURE_ON= --with-heimdal-krb5=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_HEIMDAL_CONFIGURE_ON= --with-heimdal-krb5=${GSSAPIBASEDIR} \
+ ${GSSAPI_CONFIGURE_ARGS} \
+ krb5_config=${GSSAPIBASEDIR}/bin/krb5-config
GSSAPI_HEIMDAL_PLIST_SUB= AUTH_KERB=""
GSSAPI_MIT_USES= gssapi:mit
-GSSAPI_MIT_CONFIGURE_ON= --with-mit-krb5=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_MIT_CONFIGURE_ON= --with-mit-krb5=${GSSAPIBASEDIR} \
+ ${GSSAPI_CONFIGURE_ARGS} \
+ krb5_config=${GSSAPIBASEDIR}/bin/krb5-config
GSSAPI_MIT_PLIST_SUB= AUTH_KERB=""
ARP_ACL_DESC= ARP/MAC/EUI based authentification
diff --git a/www/squid/files/patch-configure b/www/squid/files/patch-configure
index af65f16e95be..f4a9be2b73af 100644
--- a/www/squid/files/patch-configure
+++ b/www/squid/files/patch-configure
@@ -1,6 +1,24 @@
---- configure.orig 2018-07-02 03:32:06 UTC
+--- configure.orig 2019-02-19 03:04:42 UTC
+++ configure
-@@ -34345,7 +34345,7 @@ done
+@@ -26173,7 +26173,7 @@ else
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
++for as_dir in $krb5confpatth
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+@@ -26321,7 +26321,7 @@ else
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
++for as_dir in $krb5confpatth
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+@@ -34701,7 +34701,7 @@ done
##
BUILD_HELPER="NIS"
@@ -9,7 +27,7 @@
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
ac_fn_cxx_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "
-@@ -34360,8 +34360,10 @@ if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
+@@ -34716,8 +34716,10 @@ if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
_ACEOF
@@ -22,7 +40,7 @@
fi
done
-@@ -34834,7 +34836,7 @@ done
+@@ -35190,7 +35192,7 @@ done
# unconditionally requires crypt(3), for now
if test "x$ac_cv_func_crypt" != "x"; then
@@ -31,7 +49,7 @@
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
ac_fn_cxx_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
-@@ -37226,7 +37228,7 @@ for ac_header in \
+@@ -37582,7 +37584,7 @@ for ac_header in \
arpa/nameser.h \
assert.h \
bstring.h \
@@ -40,7 +58,7 @@
ctype.h \
direct.h \
errno.h \
-@@ -37434,6 +37436,7 @@ ac_fn_cxx_check_header_compile "$LINENO" "$ac_header"
+@@ -37790,6 +37792,7 @@ ac_fn_cxx_check_header_compile "$LINENO" "$ac_header"
#include <netinet/ip.h>
#endif
#if HAVE_NETINET_IP_COMPAT_H
@@ -48,7 +66,7 @@
#include <netinet/ip_compat.h>
#endif
#if HAVE_NETINET_IP_FIL_H
-@@ -41463,6 +41466,7 @@ if test "x$enable_ipf_transparent" != "xno" ; then
+@@ -41819,6 +41822,7 @@ if test "x$enable_ipf_transparent" != "xno" ; then
# include <sys/ioccom.h>
# include <netinet/in.h>
@@ -56,7 +74,7 @@
# include <netinet/ip_compat.h>
# include <netinet/ip_fil.h>
# include <netinet/ip_nat.h>
-@@ -41493,6 +41497,7 @@ else
+@@ -41849,6 +41853,7 @@ else
# include <sys/ioccom.h>
# include <netinet/in.h>
#undef minor_t
@@ -64,7 +82,7 @@
# include <netinet/ip_compat.h>
# include <netinet/ip_fil.h>
# include <netinet/ip_nat.h>
-@@ -41537,6 +41542,7 @@ _ACEOF
+@@ -41893,6 +41898,7 @@ _ACEOF
ip_fil_compat.h \
ip_fil.h \
ip_nat.h \
@@ -72,7 +90,7 @@
netinet/ip_compat.h \
netinet/ip_fil_compat.h \
netinet/ip_fil.h \
-@@ -41566,6 +41572,7 @@ ac_fn_cxx_check_header_compile "$LINENO" "$ac_header"
+@@ -41922,6 +41928,7 @@ ac_fn_cxx_check_header_compile "$LINENO" "$ac_header"
#if HAVE_IP_COMPAT_H
#include <ip_compat.h>
#elif HAVE_NETINET_IP_COMPAT_H
@@ -80,7 +98,7 @@
#include <netinet/ip_compat.h>
#endif
#if HAVE_IP_FIL_H
-@@ -41629,8 +41636,7 @@ _ACEOF
+@@ -41985,8 +41992,7 @@ _ACEOF
fi