aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-03 13:51:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-03 13:51:58 +0000
commit894cc4d1bab60ecd37af5220826eeefd15a43701 (patch)
tree136d1be5fbe4d8f2af1c7559e1e13e66af6ab73e /www/squid
parentda8b71c4c2a25cd497a87ad5c88231417f40c6c4 (diff)
downloadports-894cc4d1bab60ecd37af5220826eeefd15a43701.tar.gz
ports-894cc4d1bab60ecd37af5220826eeefd15a43701.zip
Notes
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile3
-rw-r--r--www/squid/distinfo4
-rw-r--r--www/squid/files/squid.in10
3 files changed, 13 insertions, 4 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index a3e0944933b4..ec83edc2c6d1 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= squid
-PORTVERSION= 3.5.24
-PORTREVISION= 2
+PORTVERSION= 3.5.25
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
diff --git a/www/squid/distinfo b/www/squid/distinfo
index ed9d01b76f6e..6de50d87a5f1 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1479930399
-SHA256 (squid3.5/squid-3.5.24.tar.xz) = 4fe29f582eef357faa541a53835b6885e24e6f28b80a3abcdf3b57f5393bbdb2
-SIZE (squid3.5/squid-3.5.24.tar.xz) = 2326424
+SHA256 (squid3.5/squid-3.5.25.tar.xz) = 28959254c32b8cd87e9599b6beb97352cf0638524e0f5ac3e1754f08462f3585
+SIZE (squid3.5/squid-3.5.25.tar.xz) = 2327316
diff --git a/www/squid/files/squid.in b/www/squid/files/squid.in
index 7b049c05b9ed..2044ce7904b8 100644
--- a/www/squid/files/squid.in
+++ b/www/squid/files/squid.in
@@ -42,6 +42,10 @@
# squid_krb5_ktname:
# Alternative Kerberos 5 Key Table.
# Default: none
+#
+# squid_krb5_config:
+# Alternative Kerberos 5 config file
+# Default: none
. /etc/rc.subr
@@ -89,6 +93,12 @@ squid_prestart()
export KRB5_KTNAME=${squid_krb5_ktname}
fi
+ # setup KRB5_CONFIG:
+ squid_krb5_config=${squid_krb5_config:-"NONE"}
+ if [ "${squid_krb5_config}" != "NONE" ]; then
+ export KRB5_CONFIG=${squid_krb5_config}
+ fi
+
# setup FIB tables:
if command -v check_namevarlist > /dev/null 2>&1; then
check_namevarlist fib && return 0