aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-10-01 18:31:40 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-10-01 18:31:40 +0000
commitfe04bd204a387640701e4702d564cd651e964e64 (patch)
treebaeafdba279a8e05058d611f821810dae0970b8a /www/squid
parent077479fdaeca2a9afc96aae7406c2eb6cd2f82cc (diff)
downloadports-fe04bd204a387640701e4702d564cd651e964e64.tar.gz
ports-fe04bd204a387640701e4702d564cd651e964e64.zip
Notes
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile7
-rw-r--r--www/squid/distinfo6
-rw-r--r--www/squid/files/patch-src_ssl_bio.cc14
-rw-r--r--www/squid/pkg-plist4
4 files changed, 24 insertions, 7 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index a50f061caf64..a5cef77e51e9 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -1,16 +1,14 @@
# $FreeBSD$
PORTNAME= squid
-PORTVERSION= 4.1
-PORTREVISION= 2
+PORTVERSION= 4.3
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v4/ \
http://www2.us.squid-cache.org/Versions/v4/ \
http://www1.at.squid-cache.org/Versions/v4/ \
http://www.eu.squid-cache.org/Versions/v4/ \
http://www1.jp.squid-cache.org/Versions/v4/
-#DIST_SUBDIR= squid${PORTVERSION:R}
-DIST_SUBDIR= squid${PORTVERSION}
+DIST_SUBDIR= squid${PORTVERSION:R}
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www2.us.squid-cache.org/%SUBDIR%/ \
@@ -218,6 +216,7 @@ CONFIGURE_ARGS= --with-default-user=squid \
--with-pidfile=/var/run/squid/squid.pid \
--with-swapdir=/var/squid/cache \
--without-gnutls \
+ --with-included-ltdl \
--enable-auth \
--enable-zph-qos \
--enable-build-info \
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 50670f3f4d73..c7afab8157fa 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522445865
-SHA256 (squid4.1/squid-4.1.tar.xz) = b61e486fe1ba1f5c918a48d5ae3929d3f604e347c3c7dceb1105a9f0e5ee9eb5
-SIZE (squid4.1/squid-4.1.tar.xz) = 2425892
+TIMESTAMP = 1537243691
+SHA256 (squid4/squid-4.3.tar.xz) = 322612ef0544828f6c673a25124b32364fb41ef5e2847e21c89480b5546a4c7c
+SIZE (squid4/squid-4.3.tar.xz) = 2435880
diff --git a/www/squid/files/patch-src_ssl_bio.cc b/www/squid/files/patch-src_ssl_bio.cc
new file mode 100644
index 000000000000..0526414f20c0
--- /dev/null
+++ b/www/squid/files/patch-src_ssl_bio.cc
@@ -0,0 +1,14 @@
+--- src/ssl/bio.cc.orig 2018-06-21 15:26:17 UTC
++++ src/ssl/bio.cc
+@@ -76,7 +76,11 @@ Ssl::Bio::Create(const int fd, Security:
+ BIO_meth_set_create(SquidMethods, squid_bio_create);
+ BIO_meth_set_destroy(SquidMethods, squid_bio_destroy);
+ }
++#if defined(LIBRESSL_VERSION_NUMBER)
++ BIO_METHOD *useMethod = SquidMethods;
++#elif !defined(LIBRESSL_VERSION_NUMBER)
+ const BIO_METHOD *useMethod = SquidMethods;
++#endif
+ #else
+ BIO_METHOD *useMethod = &SquidMethods;
+ #endif
diff --git a/www/squid/pkg-plist b/www/squid/pkg-plist
index 9fd2468e4f8a..9996a22970d7 100644
--- a/www/squid/pkg-plist
+++ b/www/squid/pkg-plist
@@ -62,6 +62,10 @@
%%ETCDIR%%/errors/ar-sa
%%ETCDIR%%/errors/ar-sy
%%ETCDIR%%/errors/ar-tn
+%%ETCDIR%%/errors/ca-es
+%%ETCDIR%%/errors/en-cn
+%%ETCDIR%%/errors/es-xl
+%%ETCDIR%%/errors/pt-xl
%%ETCDIR%%/errors/ar-ye
%%ETCDIR%%/errors/ar/ERR_ACCESS_DENIED
%%ETCDIR%%/errors/ar/ERR_ACL_TIME_QUOTA_EXCEEDED