aboutsummaryrefslogtreecommitdiff
path: root/www/srg/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-10-15 16:29:03 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-10-15 16:29:03 +0000
commita765d6b2fc34c1381dc872ba0638d3b1f9f3b6d6 (patch)
tree995f775e311920ae83d37bd5b3daf3099431623c /www/srg/Makefile
parent63dcf8c4136e5a32a9551cdf71e68037359ed70f (diff)
downloadports-a765d6b2fc34c1381dc872ba0638d3b1f9f3b6d6.tar.gz
ports-a765d6b2fc34c1381dc872ba0638d3b1f9f3b6d6.zip
Notes
Diffstat (limited to 'www/srg/Makefile')
-rw-r--r--www/srg/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/www/srg/Makefile b/www/srg/Makefile
index e6e2ac899f0b..b5cb72ec2992 100644
--- a/www/srg/Makefile
+++ b/www/srg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= srg
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
http://mirror.crc.net.nz/pub/srg/
@@ -15,21 +14,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
MAINTAINER= ports@FreeBSD.org
COMMENT= A Squid Report Generator
-USE_GMAKE= yes
-USE_BISON= build
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_BZIP2= yes
-NO_INSTALL_MANPAGES= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+MAN1= srg.1
post-patch:
- ${REINPLACE_CMD} -e 's|-g |${CFLAGS} ${CPPFLAGS} |' ${WRKSRC}/Makefile \
- ${WRKSRC}/lib/Makefile
- ${REINPLACE_CMD} -e 's|^\(LDFLAGS\)=|\1+=|' ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/srg ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${REINPLACE_CMD} -e \
+ '/CPPFLAGS/s|-I/usr/local/include|| ; \
+ /LDFLAGS/s|-L/usr/local/lib||' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in srg.daily srg.monthly srg.weekly
+ ${INSTALL_DATA} ${WRKSRC}/examples/${ex} ${EXAMPLESDIR}
+.endfor
.endif
.include <bsd.port.mk>