aboutsummaryrefslogtreecommitdiff
path: root/www/suphp
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-07-15 22:13:36 +0000
committerClement Laforet <clement@FreeBSD.org>2004-07-15 22:13:36 +0000
commit686ce339ee08b510dd94e97eff3a5438c771d325 (patch)
treeab5ddd129bf4ee91236ef5f39ba86a8080fc392e /www/suphp
parent8f8fb5fa36081ed10877e954a1f77ad2274ace33 (diff)
downloadports-686ce339ee08b510dd94e97eff3a5438c771d325.tar.gz
ports-686ce339ee08b510dd94e97eff3a5438c771d325.zip
Notes
Diffstat (limited to 'www/suphp')
-rw-r--r--www/suphp/Makefile12
-rw-r--r--www/suphp/distinfo4
-rw-r--r--www/suphp/files/patch-src::apache2::mod_suphp.c16
3 files changed, 24 insertions, 8 deletions
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index 13ccf09a1630..71d32978d076 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= suphp
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
CATEGORIES= www
MASTER_SITES= http://www.suphp.org/download/
-MAINTAINER= clement@FreeBSD.org
+MAINTAINER= freebsd@jdc.parodius.com
COMMENT= A combination which provides a wrapper for PHP
-RUN_DEPENDS= ${LOCALBASE}/bin/php:${PORTSDIR}/www/php4-cgi
-
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_PHP= yes
+WANT_PHP_CGI= yes
USE_APACHE= yes
CONFLICTS= mod_php4-4* php-4.*
@@ -53,9 +52,10 @@ CONFIGURE_ARGS+= --disable-checkgid
.endif
## WITH_SETID_MODE: Mode to use for setting UID/GID.
CONFIGURE_ARGS+= --with-setid-mode=${WITH_SETID_MODE}
-## WITH_LOGPATH (formerly known as LOG_PATH): logging directory
+## WITH_LOGPATH (formerly known as LOG_PATH): logging directory
## (default: /var/log)
## WITH_LOGNAME: log file name (default suphp.log)
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/include/apache2/apr.h) || defined(WITH_APACHE2)
diff --git a/www/suphp/distinfo b/www/suphp/distinfo
index 5b04f077227a..1ceadfb421c3 100644
--- a/www/suphp/distinfo
+++ b/www/suphp/distinfo
@@ -1,2 +1,2 @@
-MD5 (suphp-0.5.1.tar.gz) = 6898ccd801ec93cb7c6a69a9ac8f3703
-SIZE (suphp-0.5.1.tar.gz) = 217350
+MD5 (suphp-0.5.2.tar.gz) = 337909e87027af124052baddddbd2994
+SIZE (suphp-0.5.2.tar.gz) = 104699
diff --git a/www/suphp/files/patch-src::apache2::mod_suphp.c b/www/suphp/files/patch-src::apache2::mod_suphp.c
new file mode 100644
index 000000000000..701d2f68b9a5
--- /dev/null
+++ b/www/suphp/files/patch-src::apache2::mod_suphp.c
@@ -0,0 +1,16 @@
+--- src/apache2/mod_suphp.c.orig Tue Jul 13 02:43:41 2004
++++ src/apache2/mod_suphp.c Wed Jul 14 01:51:27 2004
+@@ -463,7 +463,13 @@
+
+ if (((rv = apr_procattr_create(&procattr, p)) != APR_SUCCESS)
+ || ((rv = apr_procattr_io_set(procattr, APR_CHILD_BLOCK, APR_CHILD_BLOCK, APR_CHILD_BLOCK)) != APR_SUCCESS)
++
++/* XXX: Pending review by both the Apache APR folks, as well as the suPHP folks. See thread:
++ * http://lists.marsching.biz/pipermail/suphp/2004-July/000756.html
++ */
++/*
+ || ((rv = apr_procattr_dir_set(procattr, ap_make_dirstr_parent(r->pool, r->filename))) != APR_SUCCESS)
++*/
+
+ /* set resource limits */
+