aboutsummaryrefslogtreecommitdiff
path: root/www/thttpd
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /www/thttpd
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
Notes
Diffstat (limited to 'www/thttpd')
-rw-r--r--www/thttpd/Makefile4
-rw-r--r--www/thttpd/files/thttpd.sh20
2 files changed, 21 insertions, 3 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index ff4fb236a0ba..6b57a4e4b8ac 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -53,9 +53,7 @@ do-install:
@${ECHO} "pidfile=/var/run/thttpd.pid" >> ${PREFIX}/etc/thttpd.conf.sample
@if [ ! -f ${PREFIX}/etc/rc.d/thttpd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/thttpd.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/thttpd.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/thttpd_wrapper ] && ${PREFIX}/sbin/thttpd_wrapper && ${ECHO} -n ' thttpd'" >> ${PREFIX}/etc/rc.d/thttpd.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/thttpd.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/thttpd.sh ${PREFIX}/etc/rc.d/thttpd.sh; \
fi
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/thttpd
diff --git a/www/thttpd/files/thttpd.sh b/www/thttpd/files/thttpd.sh
new file mode 100644
index 000000000000..34a848a96082
--- /dev/null
+++ b/www/thttpd/files/thttpd.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/thttpd_wrapper ] && ${PREFIX}/sbin/thttpd_wrapper && echo -n ' thttpd'
+ ;;
+stop)
+ killall thttpd_wrapper && killall thttpd && echo -n ' thttpd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0