aboutsummaryrefslogtreecommitdiff
path: root/www/tinyproxy
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-07-03 23:20:43 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-07-03 23:20:43 +0000
commit66f878d0d5a381eeae5e9fdf0bef820c3b94b3d8 (patch)
tree333506664fe006d65157f5722d19a04523e21267 /www/tinyproxy
parent46e9a5a2cd59a7a7f6bf0f7601ac2b42ce9aeb30 (diff)
downloadports-66f878d0d5a381eeae5e9fdf0bef820c3b94b3d8.tar.gz
ports-66f878d0d5a381eeae5e9fdf0bef820c3b94b3d8.zip
Notes
Diffstat (limited to 'www/tinyproxy')
-rw-r--r--www/tinyproxy/Makefile20
-rw-r--r--www/tinyproxy/distinfo1
-rw-r--r--www/tinyproxy/files/patch-aa27
-rw-r--r--www/tinyproxy/pkg-comment1
-rw-r--r--www/tinyproxy/pkg-descr12
-rw-r--r--www/tinyproxy/pkg-plist1
6 files changed, 62 insertions, 0 deletions
diff --git a/www/tinyproxy/Makefile b/www/tinyproxy/Makefile
new file mode 100644
index 000000000000..63cd57d06daf
--- /dev/null
+++ b/www/tinyproxy/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: tinyproxy
+# Version required: 1.2.6
+# Date created: 01 Jul 1999
+# Whom: Mitsuru Yoshida <mitsuru@riken.go.jp>
+#
+# $Id$
+#
+
+DISTNAME= tinyproxy-1.2.6
+CATEGORIES= www
+MASTER_SITES= http://tinyproxy.attacca.com/ \
+ http://www.flarenet.com/tinyproxy/
+
+MAINTAINER= mitsuru@riken.go.jp
+
+WRKSRC= ${WRKDIR}/tinyproxy
+
+MAN8= tinyproxy.8
+
+.include <bsd.port.mk>
diff --git a/www/tinyproxy/distinfo b/www/tinyproxy/distinfo
new file mode 100644
index 000000000000..622f8df69125
--- /dev/null
+++ b/www/tinyproxy/distinfo
@@ -0,0 +1 @@
+MD5 (tinyproxy-1.2.6.tar.gz) = ade0384e1b6b5d8ac9d22b890fe93eea
diff --git a/www/tinyproxy/files/patch-aa b/www/tinyproxy/files/patch-aa
new file mode 100644
index 000000000000..c22b99293ee5
--- /dev/null
+++ b/www/tinyproxy/files/patch-aa
@@ -0,0 +1,27 @@
+--- src/Makefile.orig Fri Jun 4 14:42:34 1999
++++ src/Makefile Sun Jul 4 16:15:09 1999
+@@ -1,13 +1,13 @@
+ # Written by Steven Young (sdyoung@well.com)
+ # Additions by Robert James Kaes (rjkaes@flarenet.com) 1999/02/05
+
+-CC = gcc # change this to your prefered compiler
++#CC = gcc # change this to your prefered compiler
+
+ WARN = -Wall -Wshadow -Wstrict-prototypes # Warnings
+
+ #
+ # Full Production System (No debuging info)
+-CFLAGS = -O2 ${WARN}
++CFLAGS += ${WARN}
+ #
+ # Full Debuging Version
+ #CFLAGS = -g ${WARN}
+@@ -21,7 +21,7 @@
+
+ # Set location for installation
+ INSTALL = /usr/bin/install
+-BINPATH = /usr/local/bin
++BINPATH = /usr/local/sbin
+ STRIP = /usr/bin/strip
+
+ all: ${OBJS}
diff --git a/www/tinyproxy/pkg-comment b/www/tinyproxy/pkg-comment
new file mode 100644
index 000000000000..41057fe3f373
--- /dev/null
+++ b/www/tinyproxy/pkg-comment
@@ -0,0 +1 @@
+A small, efficient HTTP proxy server
diff --git a/www/tinyproxy/pkg-descr b/www/tinyproxy/pkg-descr
new file mode 100644
index 000000000000..f8edb18b6fae
--- /dev/null
+++ b/www/tinyproxy/pkg-descr
@@ -0,0 +1,12 @@
+Tinyproxy is a lightweight, non-caching,optionally anonymizing http proxy.
+It is designed to consume a minimum of system resources.
+It listens on a given TCP port and handles HTTP proxy requests.
+
+Note that tinyproxy requires commandline arguments to run in anonymizing
+mode. For most people, "/usr/local/sbin/tinyproxy -a Host: -a Authorization:"
+is sufficient for an anonymizing proxy.
+
+WWW: http://tinyproxy.attacca.com/
+
+- Mitsuru Yoshida
+mitsuru@riken.go.jp
diff --git a/www/tinyproxy/pkg-plist b/www/tinyproxy/pkg-plist
new file mode 100644
index 000000000000..d774bef63f4f
--- /dev/null
+++ b/www/tinyproxy/pkg-plist
@@ -0,0 +1 @@
+sbin/tinyproxy