aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat7
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-09-08 09:31:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-09-08 09:31:07 +0000
commit898335a4e5856ca51d99414766fea6fc70611b1f (patch)
tree44751b05f3f3345c2bf871011503f463cff3660e /www/tomcat7
parentac9edfd67969ce040c55ee2bf49944febd284c56 (diff)
downloadports-898335a4e5856ca51d99414766fea6fc70611b1f.tar.gz
ports-898335a4e5856ca51d99414766fea6fc70611b1f.zip
Notes
Diffstat (limited to 'www/tomcat7')
-rw-r--r--www/tomcat7/Makefile1
-rw-r--r--www/tomcat7/files/tomcat55.sh.in4
2 files changed, 3 insertions, 2 deletions
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index d92c862ffad8..c311eefcdbc9 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.17
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat7/files/tomcat55.sh.in b/www/tomcat7/files/tomcat55.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/tomcat7/files/tomcat55.sh.in
+++ b/www/tomcat7/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0