aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat9/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2018-08-05 20:13:01 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2018-08-05 20:13:01 +0000
commitb371aee6966611ebfe6ca0eed382f04e0383c22b (patch)
treead9aed42556c768ac09d12e8780284df27864642 /www/tomcat9/Makefile
parent7b10d009b721267d2675496be9e526e2f53c08e8 (diff)
Notes
Diffstat (limited to 'www/tomcat9/Makefile')
-rw-r--r--www/tomcat9/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/tomcat9/Makefile b/www/tomcat9/Makefile
index 69823e95fe75..c17e1800ff92 100644
--- a/www/tomcat9/Makefile
+++ b/www/tomcat9/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tomcat
PORTVERSION= 9.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/([0-9])(.*)/\1/}/v${PORTVERSION}/bin
PKGNAMESUFFIX= 9
@@ -53,14 +53,20 @@ post-install:
@${RM} ${STAGEDIR}${TOMCAT_HOME}/bin/*.bat
(cd ${STAGEDIR}${TOMCAT_HOME}/conf &&\
for f in $$(find . -type f); do ${MV} $$f $$f.sample; done)
+
+post-install-HOST_MANAGER-on:
(cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
- for f in host-manager/META-INF/context.xml host-manager/WEB-INF/web.xml \
- manager/META-INF/context.xml manager/WEB-INF/web.xml; do \
+ for f in host-manager/META-INF/context.xml host-manager/WEB-INF/web.xml; do \
${MV} $$f $$f.sample; done)
post-install-HOST_MANAGER-off:
@${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/host-manager
+post-install-MANAGER-on:
+ (cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
+ for f in manager/META-INF/context.xml manager/WEB-INF/web.xml; do \
+ ${MV} $$f $$f.sample; done)
+
post-install-MANAGER-off:
@${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/manager