aboutsummaryrefslogtreecommitdiff
path: root/www/trac-permredirect
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-01-28 13:19:37 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-01-28 13:19:37 +0000
commit00588658f827cf1d6ce4a6fabc5253cef3e9808e (patch)
tree02fe1c747a9cc0a20c5a65c4adabfd19bbbe9eb1 /www/trac-permredirect
parenta8c217893718f0a117d5ab0feb21cb0edcf3a2fa (diff)
downloadports-00588658f827cf1d6ce4a6fabc5253cef3e9808e.tar.gz
ports-00588658f827cf1d6ce4a6fabc5253cef3e9808e.zip
Notes
Diffstat (limited to 'www/trac-permredirect')
-rw-r--r--www/trac-permredirect/Makefile36
-rw-r--r--www/trac-permredirect/distinfo2
-rw-r--r--www/trac-permredirect/pkg-descr3
3 files changed, 41 insertions, 0 deletions
diff --git a/www/trac-permredirect/Makefile b/www/trac-permredirect/Makefile
new file mode 100644
index 000000000000..011ef31e1802
--- /dev/null
+++ b/www/trac-permredirect/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: trac-permredirect
+# Date created: 2012-01-22
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= permredirect
+PORTVERSION= 2.0.${REV}
+CATEGORIES= www devel python
+MASTER_SITES= http://trac-hacks.org/changeset/${REV}/${PORTNAME}plugin/${BRANCH}?old_path=/&format=zip&filename= \
+ http://files.roorback.net/
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Redirect users to the login screen on PermissionError
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= tracd:${PORTSDIR}/www/trac
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+BRANCH= 0.11
+REV= 3593
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracPermRedirect
+PYDISTUTILS_PKGVERSION= 2.0
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/${BRANCH}
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+pre-build:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py bdist_egg
+
+.include <bsd.port.mk>
diff --git a/www/trac-permredirect/distinfo b/www/trac-permredirect/distinfo
new file mode 100644
index 000000000000..0fa4e68f1e7e
--- /dev/null
+++ b/www/trac-permredirect/distinfo
@@ -0,0 +1,2 @@
+SHA256 (permredirect-2.0.3593.zip) = 0064b7063be2ff9c605545c803d00f69ff22e5c2f62e6fcff65ec369bb71a47c
+SIZE (permredirect-2.0.3593.zip) = 1538
diff --git a/www/trac-permredirect/pkg-descr b/www/trac-permredirect/pkg-descr
new file mode 100644
index 000000000000..b9cbc19aeeae
--- /dev/null
+++ b/www/trac-permredirect/pkg-descr
@@ -0,0 +1,3 @@
+Trac plugin which redirects users to the login screen on PermissionError.
+
+WWW: http://trac-hacks.org/wiki/PermRedirectPlugin