aboutsummaryrefslogtreecommitdiff
path: root/www/ungoogled-chromium
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-01-19 17:02:25 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-01-19 17:03:16 +0000
commit982de4a7bf3bd61aa69ee829f6a30bf8e22b9e53 (patch)
treef631d8094a1fdaca4be10fcf2bed112630d2921a /www/ungoogled-chromium
parente2fdb4385d5d5c11aac9f3876dbe5efdbdef274e (diff)
downloadports-982de4a7bf3bd61aa69ee829f6a30bf8e22b9e53.tar.gz
ports-982de4a7bf3bd61aa69ee829f6a30bf8e22b9e53.zip
Diffstat (limited to 'www/ungoogled-chromium')
-rw-r--r--www/ungoogled-chromium/Makefile3
-rw-r--r--www/ungoogled-chromium/distinfo14
-rw-r--r--www/ungoogled-chromium/files/patch-chrome_browser_BUILD.gn4
-rw-r--r--www/ungoogled-chromium/files/patch-chrome_browser_chrome__browser__main.cc12
4 files changed, 16 insertions, 17 deletions
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index c42285fc6ec5..f31d9b89b70a 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ungoogled-chromium
-PORTVERSION= 120.0.6099.216
-PORTREVISION= 1
+PORTVERSION= 120.0.6099.224
UGVERSION= ${DISTVERSION}-1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
diff --git a/www/ungoogled-chromium/distinfo b/www/ungoogled-chromium/distinfo
index 0c5a2ab383e5..abeeb60bfdf9 100644
--- a/www/ungoogled-chromium/distinfo
+++ b/www/ungoogled-chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1704955013
-SHA256 (chromium-120.0.6099.216.tar.xz) = 7e7bea15bf56f3cc920bb015fed1a1b1368267299e132e795935c5cc604adfc0
-SIZE (chromium-120.0.6099.216.tar.xz) = 3296304596
-SHA256 (ungoogled-chromium-120.0.6099.216-1.tar.gz) = 131b6fec2bca4435b2542d46df716af79a62bf80fc00c48898de640dd852aa8e
-SIZE (ungoogled-chromium-120.0.6099.216-1.tar.gz) = 665895
-SHA256 (chromium-120.0.6099.216-testdata.tar.xz) = c66136fa24d77fb27c04fca4fd2fec15004efad68f551d156eab038de93f40c6
-SIZE (chromium-120.0.6099.216-testdata.tar.xz) = 271802184
+TIMESTAMP = 1705683725
+SHA256 (chromium-120.0.6099.224.tar.xz) = 850a85c8d8a01041a07dfaaea8289fa5f8294b4e375e6b77997b61434e0a2f1a
+SIZE (chromium-120.0.6099.224.tar.xz) = 3299542904
+SHA256 (ungoogled-chromium-120.0.6099.224-1.tar.gz) = b96fd3d5d64ffd5efa3bc52966adfd7fd1dd3e85ebf3517924054b577ac03750
+SIZE (ungoogled-chromium-120.0.6099.224-1.tar.gz) = 665887
+SHA256 (chromium-120.0.6099.224-testdata.tar.xz) = db8ef8f50dd759f548fd269202f9d084e3d1bb92b587bd5e0023707ac29518ea
+SIZE (chromium-120.0.6099.224-testdata.tar.xz) = 268575524
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/ungoogled-chromium/files/patch-chrome_browser_BUILD.gn b/www/ungoogled-chromium/files/patch-chrome_browser_BUILD.gn
index faa19f3b3f7f..4fef52ab5e8c 100644
--- a/www/ungoogled-chromium/files/patch-chrome_browser_BUILD.gn
+++ b/www/ungoogled-chromium/files/patch-chrome_browser_BUILD.gn
@@ -1,6 +1,6 @@
---- chrome/browser/BUILD.gn.orig 2023-12-23 12:33:28 UTC
+--- chrome/browser/BUILD.gn.orig 2024-01-17 09:38:09 UTC
+++ chrome/browser/BUILD.gn
-@@ -6508,6 +6508,13 @@ static_library("browser") {
+@@ -6526,6 +6526,13 @@ static_library("browser") {
}
}
diff --git a/www/ungoogled-chromium/files/patch-chrome_browser_chrome__browser__main.cc b/www/ungoogled-chromium/files/patch-chrome_browser_chrome__browser__main.cc
index 2609d971e6d9..1079adeec055 100644
--- a/www/ungoogled-chromium/files/patch-chrome_browser_chrome__browser__main.cc
+++ b/www/ungoogled-chromium/files/patch-chrome_browser_chrome__browser__main.cc
@@ -1,4 +1,4 @@
---- chrome/browser/chrome_browser_main.cc.orig 2023-12-23 12:33:28 UTC
+--- chrome/browser/chrome_browser_main.cc.orig 2024-01-17 09:38:09 UTC
+++ chrome/browser/chrome_browser_main.cc
@@ -246,11 +246,11 @@
@@ -31,7 +31,7 @@
#include "chrome/browser/headless/headless_mode_metrics.h" // nogncheck
#include "chrome/browser/headless/headless_mode_util.h" // nogncheck
#include "components/headless/select_file_dialog/headless_select_file_dialog.h"
-@@ -1042,7 +1042,7 @@ int ChromeBrowserMainParts::PreCreateThreadsImpl() {
+@@ -1039,7 +1039,7 @@ int ChromeBrowserMainParts::PreCreateThreadsImpl() {
browser_creator_->AddFirstRunTabs(master_prefs_->new_tabs);
}
@@ -40,7 +40,7 @@
// Create directory for user-level Native Messaging manifest files. This
// makes it less likely that the directory will be created by third-party
// software with incorrect owner or permission. See crbug.com/725513 .
-@@ -1098,7 +1098,7 @@ int ChromeBrowserMainParts::PreCreateThreadsImpl() {
+@@ -1095,7 +1095,7 @@ int ChromeBrowserMainParts::PreCreateThreadsImpl() {
// TODO(crbug.com/1052397): Revisit the macro expression once build flag switch
// of lacros-chrome is complete.
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) || \
@@ -49,7 +49,7 @@
metrics::DesktopSessionDurationTracker::Initialize();
ProfileActivityMetricsRecorder::Initialize();
TouchModeStatsTracker::Initialize(
-@@ -1334,7 +1334,7 @@ void ChromeBrowserMainParts::PostProfileInit(Profile*
+@@ -1331,7 +1331,7 @@ void ChromeBrowserMainParts::PostProfileInit(Profile*
*UrlLanguageHistogramFactory::GetForBrowserContext(profile));
#endif // BUILDFLAG(IS_CHROMEOS_ASH)
@@ -58,7 +58,7 @@
if (headless::IsHeadlessMode()) {
headless::ReportHeadlessActionMetrics();
}
-@@ -1440,7 +1440,7 @@ int ChromeBrowserMainParts::PreMainMessageLoopRunImpl(
+@@ -1437,7 +1437,7 @@ int ChromeBrowserMainParts::PreMainMessageLoopRunImpl(
// In headless mode provide alternate SelectFileDialog factory overriding
// any platform specific SelectFileDialog implementation that may have been
// set.
@@ -67,7 +67,7 @@
if (headless::IsHeadlessMode()) {
headless::HeadlessSelectFileDialogFactory::SetUp();
}
-@@ -1967,7 +1967,7 @@ bool ChromeBrowserMainParts::ProcessSingletonNotificat
+@@ -1969,7 +1969,7 @@ bool ChromeBrowserMainParts::ProcessSingletonNotificat
// Drop the request if headless mode is in effect or the request is from
// a headless Chrome process.