aboutsummaryrefslogtreecommitdiff
path: root/www/unit
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2022-12-16 03:31:56 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2022-12-16 03:32:21 +0000
commit4e0dbdeac7299f9b293e19189d188cf15115689c (patch)
treee812d0d1c0b6123c5d38e5a4f90509493b6314fa /www/unit
parent51eb528970521297150a0b8c4d170db9a16fccb9 (diff)
downloadports-4e0dbdeac7299f9b293e19189d188cf15115689c.tar.gz
ports-4e0dbdeac7299f9b293e19189d188cf15115689c.zip
www/unit: add NGINX JavaScript support
Bump PORTREVISION.
Diffstat (limited to 'www/unit')
-rw-r--r--www/unit/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/www/unit/Makefile b/www/unit/Makefile
index a2af0f9d9450..20a5e2d927ba 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -1,5 +1,6 @@
PORTNAME= unit
PORTVERSION= ${UNIT_VERSION}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES?= https://unit.nginx.org/download/
@@ -18,6 +19,7 @@ CPE_PRODUCT= unit
OPTIONS_DEFINE?= \
DEBUG \
IPV6 \
+ NJS \
SSL \
UNIXSOCK
OPTIONS_DEFAULT?= IPV6 PCRE2 SSL UNIXSOCK
@@ -27,6 +29,7 @@ OPTIONS_RADIO_REGEX= NOPCRE PCRE PCRE2
DEBUG_DESC= Enable debug logging
REGEX_DESC= Support regular expressions
+NJS_DESC= Enable NGINX JavaScript
NOPCRE_DESC= No support for Regular Expressions
PCRE_DESC= Regular Expressions via devel/pcre
PCRE2_DESC= Regular Expressions via devel/pcre2
@@ -81,6 +84,13 @@ CONFIGURE_ARGS+=--debug
CONFIGURE_ARGS+=--no-ipv6
.endif
+.if ${PORT_OPTIONS:MNJS}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libnjs.a:devel/libnjs
+CONFIGURE_ARGS+=--njs \
+ --cc-opt="-I${LOCALBASE}/include" \
+ --ld-opt="-L${LOCALBASE}/lib"
+.endif
+
.if ${PORT_OPTIONS:MNOPCRE}
CONFIGURE_ARGS+=--no-regex
.endif