aboutsummaryrefslogtreecommitdiff
path: root/www/unit
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-08-13 21:36:08 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-08-13 21:36:08 +0000
commit502908450f54e99526f033677a0c2d2a454d0bc5 (patch)
tree2f3d8cf738ce1134ca0d8ea84f295ef3b0169ef3 /www/unit
parentaa25201b870253f54c3eb010a5c7b5659f27bde6 (diff)
downloadports-502908450f54e99526f033677a0c2d2a454d0bc5.tar.gz
ports-502908450f54e99526f033677a0c2d2a454d0bc5.zip
Update from 1.18.0 to 1.19.0.
<ChangeLog> *) Feature: reworked IPC between the router process and the applications to lower latencies, increase performance, and improve scalability. *) Feature: support for an arbitrary number of wildcards in route matching patterns. *) Feature: chunked transfer encoding in proxy responses. *) Feature: basic variables support in the "pass" option. *) Feature: compatibility with PHP 8 Beta 1. Thanks to Remi Collet. *) Bugfix: the router process could crash while passing requests to an application under high load. *) Bugfix: a number of language modules failed to build on some systems; the bug had appeared in 1.18.0. *) Bugfix: time in error log messages from PHP applications could lag. *) Bugfix: reconfiguration requests could hang if an application had failed to start; the bug had appeared in 1.18.0. *) Bugfix: memory leak during reconfiguration. *) Bugfix: the daemon didn't start without language modules; the bug had appeared in 1.18.0. *) Bugfix: the router process could crash at exit. *) Bugfix: Node.js applications could crash at exit. *) Bugfix: the Ruby module could be linked against a wrong library version. </ChangeLog>
Notes
Notes: svn path=/head/; revision=544843
Diffstat (limited to 'www/unit')
-rw-r--r--www/unit/Makefile3
-rw-r--r--www/unit/distinfo6
-rw-r--r--www/unit/files/patch-fix-rootfs-build169
3 files changed, 4 insertions, 174 deletions
diff --git a/www/unit/Makefile b/www/unit/Makefile
index 3ec36a03dfb0..a0bdc402db55 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unit
-PORTVERSION= 1.18.0
-PORTREVISION= 1
+PORTVERSION= 1.19.0
CATEGORIES= www
MASTER_SITES= https://unit.nginx.org/download/
diff --git a/www/unit/distinfo b/www/unit/distinfo
index 34665b31156d..b68f2262afae 100644
--- a/www/unit/distinfo
+++ b/www/unit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1590688617
-SHA256 (unit-1.18.0.tar.gz) = 43ffa7b935b081a5e99c0cc875b823daf4f20fc1938cd3483dc7bffaf15ec089
-SIZE (unit-1.18.0.tar.gz) = 742273
+TIMESTAMP = 1597354325
+SHA256 (unit-1.19.0.tar.gz) = 8cb849420221932685689708235efbfef2024656f856b72887ae9ff1cf75f98b
+SIZE (unit-1.19.0.tar.gz) = 761292
diff --git a/www/unit/files/patch-fix-rootfs-build b/www/unit/files/patch-fix-rootfs-build
deleted file mode 100644
index 5c6a5a1498a2..000000000000
--- a/www/unit/files/patch-fix-rootfs-build
+++ /dev/null
@@ -1,169 +0,0 @@
-# HG changeset patch
-# User Tiago Natel de Moura <t.nateldemoura@f5.com>
-# Date 1590694099 -3600
-# Thu May 28 20:28:19 2020 +0100
-# Node ID 6fcd2b868ff0603173af1f13642b996805eea1eb
-# Parent 9e14c63773be52613dd47dea9fd113037f15a3eb
-Python: fixed configure script on OSX.
-
-diff --git a/auto/modules/python b/auto/modules/python
---- a/auto/modules/python
-+++ b/auto/modules/python
-@@ -68,7 +68,6 @@ if /bin/sh -c "$NXT_PYTHON_CONFIG --pref
- NXT_PYTHON_CONFIG="${NXT_PYTHON_CONFIG} --embed"
- fi
-
-- NXT_PYTHON_EXEC=`${NXT_PYTHON_CONFIG} --exec-prefix`/bin/${NXT_PYTHON}
- NXT_PYTHON_INCLUDE=`${NXT_PYTHON_CONFIG} --includes`
- NXT_PYTHON_LIBS=`${NXT_PYTHON_CONFIG} --ldflags`
-
-@@ -133,7 +132,7 @@ fi
-
- NXT_PYTHON_MOUNTS_HEADER=$NXT_BUILD_DIR/nxt_python_mounts.h
-
--$NXT_PYTHON_EXEC -c 'import os.path
-+$NXT_PYTHON -c 'import os.path
- import sys
- pyver = "python" + str(sys.version_info[0]) + "." + str(sys.version_info[1])
-
-# HG changeset patch
-# User Tiago Natel de Moura <t.nateldemoura@f5.com>
-# Date 1590694548 -3600
-# Thu May 28 20:35:48 2020 +0100
-# Node ID 9c63e42284103b24c9f23639ac9c71c91793136b
-# Parent 6fcd2b868ff0603173af1f13642b996805eea1eb
-Isolation: fixed build when features aren't detected.
-
-diff --git a/auto/isolation b/auto/isolation
---- a/auto/isolation
-+++ b/auto/isolation
-@@ -111,7 +111,7 @@ nxt_feature_libs=
- nxt_feature_test="#include <sys/mount.h>
-
- int main() {
-- return MS_BIND | MS_REC
-+ return MS_BIND | MS_REC;
- }"
- . auto/feature
-
-diff --git a/src/nxt_application.c b/src/nxt_application.c
---- a/src/nxt_application.c
-+++ b/src/nxt_application.c
-@@ -474,20 +474,24 @@ nxt_discovery_quit(nxt_task_t *task, nxt
- static nxt_int_t
- nxt_app_prefork(nxt_task_t *task, nxt_process_t *process, nxt_mp_t *mp)
- {
-- nxt_int_t cap_setid, cap_chroot;
-+ nxt_int_t cap_setid;
- nxt_int_t ret;
- nxt_runtime_t *rt;
- nxt_common_app_conf_t *app_conf;
-- nxt_app_lang_module_t *lang;
-
- rt = task->thread->runtime;
- app_conf = process->data.app;
- cap_setid = rt->capabilities.setid;
-+
-+#if (NXT_HAVE_ISOLATION_ROOTFS)
-+ nxt_int_t cap_chroot;
-+ nxt_app_lang_module_t *lang;
-+
- cap_chroot = rt->capabilities.chroot;
--
- lang = nxt_app_lang_module(rt, &app_conf->type);
-
- nxt_assert(lang != NULL);
-+#endif
-
- if (app_conf->isolation != NULL) {
- ret = nxt_app_set_isolation(task, app_conf->isolation, process);
-@@ -499,7 +503,10 @@ nxt_app_prefork(nxt_task_t *task, nxt_pr
- #if (NXT_HAVE_CLONE_NEWUSER)
- if (nxt_is_clone_flag_set(process->isolation.clone.flags, NEWUSER)) {
- cap_setid = 1;
-+
-+#if (NXT_HAVE_ISOLATION_ROOTFS)
- cap_chroot = 1;
-+#endif
- }
- #endif
-
-diff --git a/src/nxt_process.c b/src/nxt_process.c
---- a/src/nxt_process.c
-+++ b/src/nxt_process.c
-@@ -37,13 +37,11 @@ static void nxt_process_created_error(nx
- static nxt_int_t nxt_process_chroot(nxt_task_t *task, const char *path);
- #endif
-
--#if (NXT_HAVE_PIVOT_ROOT)
-+#if (NXT_HAVE_ISOLATION_ROOTFS) && (NXT_HAVE_PIVOT_ROOT) \
-+ && (NXT_HAVE_CLONE_NEWNS)
- static nxt_int_t nxt_process_pivot_root(nxt_task_t *task, const char *rootfs);
- static nxt_int_t nxt_process_private_mount(nxt_task_t *task,
- const char *rootfs);
--#endif
--
--#if (NXT_HAVE_PIVOT_ROOT)
- static int nxt_pivot_root(const char *new_root, const char *old_root);
- #endif
-
-@@ -590,11 +588,6 @@ nxt_process_change_root(nxt_task_t *task
- #endif
-
-
--#endif
--
--
--#if (NXT_HAVE_ISOLATION_ROOTFS)
--
- static nxt_int_t
- nxt_process_chroot(nxt_task_t *task, const char *path)
- {
-@@ -625,8 +618,6 @@ nxt_process_unmount_all(nxt_task_t *task
- }
- }
-
--#endif
--
-
- #if (NXT_HAVE_PIVOT_ROOT) && (NXT_HAVE_CLONE_NEWNS)
-
-@@ -856,6 +847,8 @@ nxt_pivot_root(const char *new_root, con
-
- #endif
-
-+#endif
-+
-
- static nxt_int_t
- nxt_process_send_ready(nxt_task_t *task, nxt_process_t *process)
-diff --git a/src/perl/nxt_perl_psgi.c b/src/perl/nxt_perl_psgi.c
---- a/src/perl/nxt_perl_psgi.c
-+++ b/src/perl/nxt_perl_psgi.c
-@@ -118,12 +118,8 @@ NXT_EXPORT nxt_app_module_t nxt_app_mod
- nxt_perl_psgi_compat,
- nxt_string("perl"),
- PERL_VERSION_STRING,
--
--#if (NXT_HAVE_ISOLATION_ROOTFS)
- NULL,
- 0,
--#endif
--
- NULL,
- nxt_perl_psgi_start,
- };
-diff --git a/src/ruby/nxt_ruby.c b/src/ruby/nxt_ruby.c
---- a/src/ruby/nxt_ruby.c
-+++ b/src/ruby/nxt_ruby.c
-@@ -79,10 +79,8 @@ NXT_EXPORT nxt_app_module_t nxt_app_mod
- compat,
- nxt_string("ruby"),
- ruby_version,
--#if (NXT_HAVE_ISOLATION_ROOTFS)
- nxt_ruby_mounts,
- nxt_nitems(nxt_ruby_mounts),
--#endif
- NULL,
- nxt_ruby_start,
- };