aboutsummaryrefslogtreecommitdiff
path: root/www/unit
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-03-12 20:37:10 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-03-12 20:37:10 +0000
commit5bef081df41b5c55421fa971b96f6dedce6998f7 (patch)
tree317178dac14f7ff0484ba241d8c4529d9971cee1 /www/unit
parent25b7de7213eea407d171f3e65f8d682a8482847b (diff)
downloadports-5bef081df41b5c55421fa971b96f6dedce6998f7.tar.gz
ports-5bef081df41b5c55421fa971b96f6dedce6998f7.zip
Update from 1.15.0 to 1.16.0.
Sort knobs, configure arguments, and sub list. This release improves the functionality related to proxying and static media asset handling, please visit http://mailman.nginx.org/pipermail/unit/2020-March/000195.html to get more details. <ChangeLog> *) Feature: basic load-balancing support with round-robin. *) Feature: a "fallback" option that performs an alternative action if a request can't be served from the "share" directory. *) Feature: reduced memory consumption by dumping large request bodies to disk. *) Feature: stripping UTF-8 BOM and JavaScript-style comments from uploaded JSON. *) Bugfix: negative address matching in router might work improperly in combination with non-negative patterns. *) Bugfix: Java Spring applications failed to run; the bug had appeared in 1.10.0. *) Bugfix: PHP 7.4 was broken if it was built with thread safety enabled. *) Bugfix: compatibility issues with some Python applications. </ChangeLog>
Notes
Notes: svn path=/head/; revision=528319
Diffstat (limited to 'www/unit')
-rw-r--r--www/unit/Makefile21
-rw-r--r--www/unit/distinfo6
2 files changed, 15 insertions, 12 deletions
diff --git a/www/unit/Makefile b/www/unit/Makefile
index 133eee3b4075..12d24d77bab1 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unit
-PORTVERSION= 1.15.0
-PORTREVISION= 1
+PORTVERSION= 1.16.0
CATEGORIES= www
MASTER_SITES= https://unit.nginx.org/download/
@@ -36,27 +35,29 @@ UNIXSOCK_DESC= Enable unix sockets
HAS_CONFIGURE= yes
UNIT_VARDIR?= /var
-UNIT_RUNDIR?= ${UNIT_VARDIR}/run/unit
UNIT_LOGDIR?= ${UNIT_VARDIR}/log/${PORTNAME}
UNIT_LOGFILE?= ${UNIT_LOGDIR}/${PORTNAME}.log
UNIT_PIDFILE?= ${UNIT_RUNDIR}/${PORTNAME}.pid
+UNIT_RUNDIR?= ${UNIT_VARDIR}/run/unit
UNIT_SOCK?= ${UNIT_RUNDIR}/control.unit.sock
+UNIT_TMPDIR?= ${UNIT_VARDIR}/tmp/unit
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --modules=libexec/unit/modules \
- --state=libexec/unit \
+ --ld-opt="-L${LOCALBASE}/lib" \
--log=${UNIT_LOGFILE} \
+ --modules=libexec/unit/modules \
--pid=${UNIT_PIDFILE} \
- --ld-opt="-L${LOCALBASE}/lib"
+ --state=libexec/unit \
+ --tmp=${UNIT_TMPDIR}
PLIST_FILES?= sbin/unitd
PLIST_DIRS?= libexec/unit/modules \
libexec/unit
USE_RC_SUBR?= unitd
-SUB_LIST= UNIT_PIDFILE=${UNIT_PIDFILE} \
- UNIT_SOCK=${UNIT_SOCK} \
- PREFIX=${PREFIX}
+SUB_LIST= PREFIX=${PREFIX} \
+ UNIT_PIDFILE=${UNIT_PIDFILE} \
+ UNIT_SOCK=${UNIT_SOCK}
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--debug
@@ -97,8 +98,10 @@ post-build-DEVKIT-on:
post-install:
${MKDIR} ${STAGEDIR}${UNIT_LOGDIR}
${MKDIR} ${STAGEDIR}${UNIT_RUNDIR}
+ ${MKDIR} ${STAGEDIR}${UNIT_TMPDIR}
${ECHO_CMD} @dir ${UNIT_LOGDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_RUNDIR} >> ${TMPPLIST}
+ ${ECHO_CMD} @dir ${UNIT_TMPDIR} >> ${TMPPLIST}
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unit/modules
post-install-DEVKIT-on:
diff --git a/www/unit/distinfo b/www/unit/distinfo
index 7bbfa9f9a5ef..a642be88a719 100644
--- a/www/unit/distinfo
+++ b/www/unit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1581010116
-SHA256 (unit-1.15.0.tar.gz) = f8b231d02865b5695825a2a77ecbfd0cff33c0954c0d351d2d773d7e5f6237dd
-SIZE (unit-1.15.0.tar.gz) = 712284
+TIMESTAMP = 1584043767
+SHA256 (unit-1.16.0.tar.gz) = 6a5954c16a9f940b4ef6e40331e854f5ae7b954838991fef1db4148b8b97d563
+SIZE (unit-1.16.0.tar.gz) = 722942