aboutsummaryrefslogtreecommitdiff
path: root/www/unit
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-05-12 14:35:33 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-05-12 14:36:16 +0000
commit6684134299d5750fc4c390646a4410e13497e51d (patch)
tree6daad69d44b4ac24a1c9afcea78ff86def03dff0 /www/unit
parentc4b6c4dc6d4d2f2ecf82e58308d8097ca1b905fe (diff)
downloadports-6684134299d5750fc4c390646a4410e13497e51d.tar.gz
ports-6684134299d5750fc4c390646a4410e13497e51d.zip
*/*unit*: update NGINX Unit: 1.29.1 -> 1.30.0
<ChangeLog> *) Change: remove Unix domain listen sockets upon reconfiguration. *) Feature: basic URI rewrite support. *) Feature: NJS loadable modules support. *) Feature: per-application logging. *) Feature: conditional logging of route selection. *) Feature: support the keys API on the request objects in NJS. *) Feature: default values for 'make install' pathnames such as prefix; this allows to './configure && make && sudo make install'. *) Feature: "server_version" setting to omit the version token from "Server" header field. *) Bugfix: request header field values could be corrupted in some cases; the bug had appeared in 1.29.0. *) Bugfix: PHP error handling (added missing 403 and 404 errors). *) Bugfix: Perl applications crash on second responder call. </ChangeLog>
Diffstat (limited to 'www/unit')
-rw-r--r--www/unit/Makefile12
-rw-r--r--www/unit/distinfo6
-rw-r--r--www/unit/version.mk2
3 files changed, 12 insertions, 8 deletions
diff --git a/www/unit/Makefile b/www/unit/Makefile
index df85abe9fd58..018e336e7b0f 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -51,10 +51,12 @@ UNIT_TMPDIR?= ${UNIT_VARDIR}/tmp/unit
CONFIGURE_ARGS= --prefix=${PREFIX} \
--ld-opt="-L${LOCALBASE}/lib" \
--log=${UNIT_LOGFILE} \
- --modules=libexec/unit/modules \
+ --logdir=${UNIT_LOGDIR} \
+ --modulesdir=${PREFIX}/libexec/unit/modules \
--pid=${UNIT_PIDFILE} \
- --state=${UNIT_DBDIR} \
- --tmp=${UNIT_TMPDIR} \
+ --runstatedir=${UNIT_RUNDIR} \
+ --statedir=${UNIT_DBDIR} \
+ --tmpdir=${UNIT_TMPDIR} \
--user=${WWWOWN} --group=${WWWGRP}
USERS?= ${WWWOWN}
@@ -84,6 +86,7 @@ CONFIGURE_ARGS+=--no-ipv6
.endif
.if ${PORT_OPTIONS:MNJS}
+USES+= pkgconfig
BUILD_DEPENDS+= ${LOCALBASE}/lib/libnjs.a:devel/libnjs
CONFIGURE_ARGS+=--njs \
--cc-opt="-I${LOCALBASE}/include" \
@@ -132,7 +135,8 @@ post-install:
${ECHO_CMD} @dir ${UNIT_RUNDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_TMPDIR} >> ${TMPPLIST}
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unit/modules
- ${INSTALL_MAN} ${WRKSRC}/build/unitd.8 ${STAGEDIR}${MAN8PREFIX}/share/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/build/share/man/man8/unitd.8 \
+ ${STAGEDIR}${MAN8PREFIX}/share/man/man8
.endif
.include "../../www/unit/version.mk"
diff --git a/www/unit/distinfo b/www/unit/distinfo
index 9f8623349734..1f2da79c10fb 100644
--- a/www/unit/distinfo
+++ b/www/unit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677622904
-SHA256 (unit-1.29.1.tar.gz) = 7d756cff8c1a40b38c313fdbe8748333ffce034a3916fa1b502d63cc10623437
-SIZE (unit-1.29.1.tar.gz) = 906654
+TIMESTAMP = 1683828429
+SHA256 (unit-1.30.0.tar.gz) = 129ba1b3c4e33dfadbd38683f0634152d8ecf770cacf3af50ee50b5683dc498b
+SIZE (unit-1.30.0.tar.gz) = 894843
diff --git a/www/unit/version.mk b/www/unit/version.mk
index d39edbc53d7a..9b269d2d71b3 100644
--- a/www/unit/version.mk
+++ b/www/unit/version.mk
@@ -2,6 +2,6 @@
UNITVERSION_MK= defined
# Define NGINX Unit's version.
-UNIT_VERSION= 1.29.1
+UNIT_VERSION= 1.30.0
.endif # UNITVERSION_MK