aboutsummaryrefslogtreecommitdiff
path: root/www/uwsgi
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-06-03 11:31:51 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-06-03 11:31:51 +0000
commit0d7b596442326838765f695e3b8a7e33b51ac869 (patch)
tree5f62b2c0485db7d9df41bdc0bad776060e8ad028 /www/uwsgi
parent94bd6aa7285a63042b07e7862b9dafab4c297d69 (diff)
downloadports-0d7b596442326838765f695e3b8a7e33b51ac869.tar.gz
ports-0d7b596442326838765f695e3b8a7e33b51ac869.zip
Notes
Diffstat (limited to 'www/uwsgi')
-rw-r--r--www/uwsgi/Makefile6
-rw-r--r--www/uwsgi/distinfo4
-rw-r--r--www/uwsgi/files/patch-buildconf-base.ini18
-rw-r--r--www/uwsgi/files/patch-uwsgiconfig.py18
-rw-r--r--www/uwsgi/pkg-plist2
5 files changed, 42 insertions, 6 deletions
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
index 8c43eb5b945a..3f8dd414e967 100644
--- a/www/uwsgi/Makefile
+++ b/www/uwsgi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= uwsgi
-PORTVERSION= 1.9.10
+PORTVERSION= 1.9.11
CATEGORIES= www python
MASTER_SITES= http://projects.unbit.it/downloads/
@@ -14,10 +14,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MAKE_JOBS_SAFE= yes
-USE_GNOME= libxml2
USE_PYTHON= yes
USE_RC_SUBR= uwsgi
+PLIST_FILES= bin/uwsgi \
+ %%PYTHON_SITELIBDIR%%/uwsgidecorators.py
+
post-patch:
${REINPLACE_CMD} -e 's|python|${PYTHON_CMD}|' ${WRKSRC}/Makefile
diff --git a/www/uwsgi/distinfo b/www/uwsgi/distinfo
index 6f9e5373bec6..aab134377315 100644
--- a/www/uwsgi/distinfo
+++ b/www/uwsgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (uwsgi-1.9.10.tar.gz) = 2d01dbd3e04901e400b075287a262edc808cce84ff403e9f6f73bbcbf77e05c3
-SIZE (uwsgi-1.9.10.tar.gz) = 621553
+SHA256 (uwsgi-1.9.11.tar.gz) = e566163a7ffd18f341a0de8462d22410ee58b1f5f54c468e3019f47b7e5c4aa4
+SIZE (uwsgi-1.9.11.tar.gz) = 634255
diff --git a/www/uwsgi/files/patch-buildconf-base.ini b/www/uwsgi/files/patch-buildconf-base.ini
new file mode 100644
index 000000000000..10fe487c7e2a
--- /dev/null
+++ b/www/uwsgi/files/patch-buildconf-base.ini
@@ -0,0 +1,18 @@
+--- buildconf/base.ini.orig 2013-05-26 10:08:32.000000000 +0400
++++ buildconf/base.ini 2013-06-03 15:17:01.000000000 +0400
+@@ -1,10 +1,10 @@
+ [uwsgi]
+-xml = auto
++xml = false
+ yaml = true
+-json = auto
+-zeromq = auto
+-ssl = auto
+-pcre = auto
++json = false
++zeromq = false
++ssl = false
++pcre = false
+ routing = auto
+ debug = false
+ unbit = false
diff --git a/www/uwsgi/files/patch-uwsgiconfig.py b/www/uwsgi/files/patch-uwsgiconfig.py
new file mode 100644
index 000000000000..b6163dd29194
--- /dev/null
+++ b/www/uwsgi/files/patch-uwsgiconfig.py
@@ -0,0 +1,18 @@
+--- uwsgiconfig.py.orig 2013-05-26 10:08:32.000000000 +0400
++++ uwsgiconfig.py 2013-06-03 15:21:58.000000000 +0400
+@@ -613,15 +613,6 @@
+ self.cflags.append('-DUWSGI_HAS_IFADDRS')
+ report['ifaddrs'] = True
+
+- if uwsgi_os in ('FreeBSD', 'OpenBSD'):
+- if self.has_include('execinfo.h') or os.path.exists('/usr/local/include/execinfo.h'):
+- if os.path.exists('/usr/local/include/execinfo.h'):
+- self.cflags.append('-I/usr/local/include')
+- self.ldflags.append('-L/usr/local/lib')
+- self.cflags.append('-DUWSGI_HAS_EXECINFO')
+- self.libs.append('-lexecinfo')
+- report['execinfo'] = True
+-
+ if self.has_include('zlib.h'):
+ self.cflags.append('-DUWSGI_ZLIB')
+ self.libs.append('-lz')
diff --git a/www/uwsgi/pkg-plist b/www/uwsgi/pkg-plist
deleted file mode 100644
index e883ab3d9034..000000000000
--- a/www/uwsgi/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/uwsgi
-%%PYTHON_SITELIBDIR%%/uwsgidecorators.py