aboutsummaryrefslogtreecommitdiff
path: root/www/varnish
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2011-08-30 23:50:20 +0000
committerAnders Nordby <anders@FreeBSD.org>2011-08-30 23:50:20 +0000
commitf34c47019a0684ff3a88a3226f5f3c0787e68db3 (patch)
tree83a44a2458dcff84a75b1e4fda42dd55088c242a /www/varnish
parentedd874affacbf13293220ec8bc6a1bb4adcb4fdd (diff)
downloadports-f34c47019a0684ff3a88a3226f5f3c0787e68db3.tar.gz
ports-f34c47019a0684ff3a88a3226f5f3c0787e68db3.zip
Notes
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile23
-rw-r--r--www/varnish/distinfo6
-rw-r--r--www/varnish/files/patch-bin-varnishadm-varnishadm.c15
-rw-r--r--www/varnish/files/patch-configure.ac28
-rw-r--r--www/varnish/pkg-plist19
5 files changed, 87 insertions, 4 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 861d0dda9bea..2eebcede4225 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= varnish
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.1
CATEGORIES= www
MASTER_SITES= http://repo.varnish-cache.org/source/
@@ -26,6 +26,10 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}
CONFIGURE_ENV= RST2MAN=true
USE_LDCONFIG= yes
USE_GNOME= pkgconfig
+USE_AUTOTOOLS= aclocal libtool libtoolize autoheader automake autoconf
+ACLOCAL_ARGS= -I m4
+LIBTOOLFLAGS= --copy --force
+AUTOMAKE_ARGS= --add-missing --copy --foreign
MAN1= varnishadm.1 varnishd.1 varnishhist.1 varnishlog.1 \
varnishncsa.1 varnishreplay.1 varnishsizes.1 \
@@ -35,6 +39,13 @@ MAN7= vcl.7 varnish-cli.7
USE_RC_SUBR= varnishd varnishlog varnishncsa
SUB_FILES= pkg-message
+.if defined(WITH_VARNISHNCSA_B)
+# I still find a use for varnishncsa -b, even though Varnish developers does
+# not seem to want to keep this option. - anders@FreeBSD.org 2011-08-31
+PATCH_SITES+= http://anders.fupp.net/distfiles/:ncsab
+PATCHFILES+= patch-varnishncsa-3.0.0.diff:ncsab
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 601000
@@ -43,9 +54,17 @@ BROKEN= does not compile
post-patch:
@${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.am
post-install:
+ @${MKDIR} ${PREFIX}/share/varnish
+ @${INSTALL_SCRIPT} ${WRKSRC}/lib/libvmod_std/vmod.py ${PREFIX}/share/varnish
+.for f in cache.h heritage.h steps.h common.h acct_fields.h locks.h
+ @${INSTALL_DATA} ${WRKSRC}/bin/varnishd/${f} ${PREFIX}/include/varnish
+.endfor
+.for f in vct.h vmod_abi.h vrt.h vqueue.h vsb.h libvarnish.h miniobj.h vas.h vav.h http_headers.h vcl_returns.h
+ @${INSTALL_DATA} ${WRKSRC}/include/${f} ${PREFIX}/include/varnish
+.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/varnish/distinfo b/www/varnish/distinfo
index 3dd1af4700e9..49e4aff92adb 100644
--- a/www/varnish/distinfo
+++ b/www/varnish/distinfo
@@ -1,2 +1,4 @@
-SHA256 (varnish-3.0.0.tar.gz) = 30c4c931a50eab8e78a39a776b85cbb4d242f9ddb707e04e7876fb29f3a8a5eb
-SIZE (varnish-3.0.0.tar.gz) = 2013974
+SHA256 (varnish-3.0.1.tar.gz) = 385807737777a392520c5334bb114f9fc0e5f8dbf5cc48b420baf5b0478eb279
+SIZE (varnish-3.0.1.tar.gz) = 2123838
+SHA256 (patch-varnishncsa-3.0.0.diff) = d0794683e9fb11693384a6aca50f7b9a68c8b3276ae0d70b4fd93674fcd899d3
+SIZE (patch-varnishncsa-3.0.0.diff) = 487
diff --git a/www/varnish/files/patch-bin-varnishadm-varnishadm.c b/www/varnish/files/patch-bin-varnishadm-varnishadm.c
new file mode 100644
index 000000000000..8418753be206
--- /dev/null
+++ b/www/varnish/files/patch-bin-varnishadm-varnishadm.c
@@ -0,0 +1,15 @@
+--- bin/varnishadm/varnishadm.c.orig 2011-08-29 10:45:24.000000000 +0200
++++ bin/varnishadm/varnishadm.c 2011-08-30 23:33:47.000000000 +0200
+@@ -38,8 +38,12 @@
+ #include <sys/socket.h>
+
+ #ifdef HAVE_LIBEDIT
++#ifdef __FreeBSD__
++#include <readline/readline.h>
++#else
+ #include <editline/readline.h>
+ #endif
++#endif
+
+ #include "vcli.h"
+ #include "cli_common.h"
diff --git a/www/varnish/files/patch-configure.ac b/www/varnish/files/patch-configure.ac
new file mode 100644
index 000000000000..1a82d3e9aa06
--- /dev/null
+++ b/www/varnish/files/patch-configure.ac
@@ -0,0 +1,28 @@
+--- configure.ac.orig 2011-08-30 11:15:59.000000000 +0200
++++ configure.ac 2011-08-31 01:36:16.000000000 +0200
+@@ -138,9 +138,22 @@
+ AC_SUBST(PCRE_CFLAGS)
+ AC_SUBST(PCRE_LIBS)
+
+-PKG_CHECK_MODULES([LIBEDIT], [libedit],
+- [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
+- [AC_MSG_WARN([libedit not found, disabling libedit support])])
++case $target in
++*-*-freebsd*)
++ AC_CHECK_LIB(edit, el_init,
++ [ AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])
++ LIBEDIT_CFLAGS=""
++ LIBEDIT_LIBS="-ledit"
++ ],
++ [AC_MSG_WARN([libedit not found, disabling libedit support])])
++ ;;
++*)
++ PKG_CHECK_MODULES([LIBEDIT], [libedit],
++ [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
++ [AC_MSG_WARN([libedit not found, disabling libedit support])])
++ ;;
++esac
++
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/www/varnish/pkg-plist b/www/varnish/pkg-plist
index e021cc3b0cea..aac37e68e15f 100644
--- a/www/varnish/pkg-plist
+++ b/www/varnish/pkg-plist
@@ -8,8 +8,25 @@ bin/varnishstat
bin/varnishtest
bin/varnishtop
etc/varnish/default.vcl
+include/varnish/acct_fields.h
+include/varnish/cache.h
+include/varnish/common.h
+include/varnish/heritage.h
+include/varnish/http_headers.h
+include/varnish/libvarnish.h
+include/varnish/locks.h
+include/varnish/miniobj.h
+include/varnish/steps.h
include/varnish/varnishapi.h
+include/varnish/vas.h
+include/varnish/vav.h
+include/varnish/vcl_returns.h
include/varnish/vcli.h
+include/varnish/vct.h
+include/varnish/vmod_abi.h
+include/varnish/vqueue.h
+include/varnish/vrt.h
+include/varnish/vsb.h
include/varnish/vsc.h
include/varnish/vsc_all.h
include/varnish/vsc_fields.h
@@ -37,9 +54,11 @@ lib/libvarnishapi.la
lib/libvarnishapi.a
libdata/pkgconfig/varnishapi.pc
sbin/varnishd
+share/varnish/vmod.py
@exec [ -d %D/varnish ] || mkdir %D/varnish
@dirrmtry lib/varnish/vmods
@dirrmtry lib/varnish
@dirrmtry varnish
@dirrm include/varnish
+@dirrm share/varnish
@dirrmtry etc/varnish