aboutsummaryrefslogtreecommitdiff
path: root/www/webalizer
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-07-08 03:28:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-07-08 03:28:01 +0000
commit821e0e5675f364b7912a70df16ecd6846b5dbc1e (patch)
treeae56c0a638286240c7a184fde25e7871244c0d5c /www/webalizer
parent17a8f323dc68f2caceb5a0ba06dfd072d51ea57c (diff)
downloadports-821e0e5675f364b7912a70df16ecd6846b5dbc1e.tar.gz
ports-821e0e5675f364b7912a70df16ecd6846b5dbc1e.zip
Notes
Diffstat (limited to 'www/webalizer')
-rw-r--r--www/webalizer/Makefile2
-rw-r--r--www/webalizer/files/patch-lowercase-url-bug32
2 files changed, 33 insertions, 1 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 6e8e12d6adc8..2c186dfe72bc 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webalizer
PORTVERSION= 2.1.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= www
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
ftp://ftp.dinoex.de/pub/FreeBSD/distfiles/
diff --git a/www/webalizer/files/patch-lowercase-url-bug b/www/webalizer/files/patch-lowercase-url-bug
new file mode 100644
index 000000000000..29d7ac8710ef
--- /dev/null
+++ b/www/webalizer/files/patch-lowercase-url-bug
@@ -0,0 +1,32 @@
+--- webalizer.c 2002-04-16 18:11:31.000000000 -0400
++++ webalizer.c.new 2003-07-07 12:35:45.000000000 -0400
+@@ -688,6 +688,14 @@
+ /* un-escape URL */
+ unescape(log_rec.url);
+
++ /* strip query portion of cgi scripts */
++ cp1 = log_rec.url;
++ while (*cp1 != '\0')
++ if (!isurlchar(*cp1)) { *cp1 = '\0'; break; }
++ else cp1++;
++ if (log_rec.url[0]=='\0')
++ { log_rec.url[0]='/'; log_rec.url[1]='\0'; }
++
+ /* check for service (ie: http://) and lowercase if found */
+ if ( (cp2=strstr(log_rec.url,"://")) != NULL)
+ {
+@@ -699,14 +707,6 @@
+ }
+ }
+
+- /* strip query portion of cgi scripts */
+- cp1 = log_rec.url;
+- while (*cp1 != '\0')
+- if (!isurlchar(*cp1)) { *cp1 = '\0'; break; }
+- else cp1++;
+- if (log_rec.url[0]=='\0')
+- { log_rec.url[0]='/'; log_rec.url[1]='\0'; }
+-
+ /* strip off index.html (or any aliases) */
+ lptr=index_alias;
+ while (lptr!=NULL)