aboutsummaryrefslogtreecommitdiff
path: root/www/webkit2-gtk3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-11-11 20:53:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-11-11 20:53:34 +0000
commit15fc15f4461bc0cd5d798e4e07cf8f0ae9c43f5d (patch)
tree8de3401878ff5197ffd8e9af80e65aee4a819b38 /www/webkit2-gtk3
parenta36a7e58284b1b5c2e8821cde3f24462d45c7280 (diff)
downloadports-15fc15f4461bc0cd5d798e4e07cf8f0ae9c43f5d.tar.gz
ports-15fc15f4461bc0cd5d798e4e07cf8f0ae9c43f5d.zip
Update Webkit2-gtk3 to 2.22.3.
* Regen patches Obtained from: GNOME devel repo
Notes
Notes: svn path=/head/; revision=484767
Diffstat (limited to 'www/webkit2-gtk3')
-rw-r--r--www/webkit2-gtk3/Makefile5
-rw-r--r--www/webkit2-gtk3/distinfo6
-rw-r--r--www/webkit2-gtk3/files/patch-CMakeLists.txt4
-rw-r--r--www/webkit2-gtk3/files/patch-Source_JavaScriptCore_assembler_ARM64Assembler.h8
-rw-r--r--www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb4
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WTF_wtf_Optional.h4
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WTF_wtf_Platform.h6
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_PAL_pal_PlatformGTK.cmake8
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.h15
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_egl_GLContextEGL.cpp4
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_platform_network_soup_SoupNetworkSession.h6
-rw-r--r--www/webkit2-gtk3/files/patch-Source__JavaScriptCore__assembler__ARMAssembler.h4
-rw-r--r--www/webkit2-gtk3/files/patch-Source_bmalloc_bmalloc_BPlatform.h4
-rw-r--r--www/webkit2-gtk3/pkg-plist14
14 files changed, 43 insertions, 49 deletions
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index 9de335c13bf7..1978e31e1003 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= webkit
-PORTVERSION= 2.20.5
-PORTREVISION= 2
+PORTVERSION= 2.22.3
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3
@@ -34,7 +33,7 @@ LIB_DEPENDS= libenchant-2.so:textproc/enchant2 \
PORTSCOUT= limitw:1,even
-USES= bison cmake:outsource compiler:c++14-lang gettext gnome gperf \
+USES= bison cmake:outsource compiler:c++14-lang gettext gl gnome gperf \
jpeg localbase:ldflags perl5 pkgconfig python:2.7,build \
sqlite tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build libxml2 libxslt
diff --git a/www/webkit2-gtk3/distinfo b/www/webkit2-gtk3/distinfo
index 419a1db4349d..09abeedf1012 100644
--- a/www/webkit2-gtk3/distinfo
+++ b/www/webkit2-gtk3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534713029
-SHA256 (webkitgtk-2.20.5.tar.xz) = 15c0f8d26e9605afe0948d161ba5fd82efee8eda2debd409fd40a440ac3af990
-SIZE (webkitgtk-2.20.5.tar.xz) = 16625200
+TIMESTAMP = 1540925863
+SHA256 (webkitgtk-2.22.3.tar.xz) = 9dfd542902953be9af8ff32bd37fe662ca3d75f7348514ebac15c6252a6ccd72
+SIZE (webkitgtk-2.22.3.tar.xz) = 16753248
diff --git a/www/webkit2-gtk3/files/patch-CMakeLists.txt b/www/webkit2-gtk3/files/patch-CMakeLists.txt
index 3249edf99fc7..5eef8cd9813b 100644
--- a/www/webkit2-gtk3/files/patch-CMakeLists.txt
+++ b/www/webkit2-gtk3/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2018-02-19 07:44:43 UTC
+--- CMakeLists.txt.orig 2018-09-06 11:51:31 UTC
+++ CMakeLists.txt
-@@ -93,9 +93,9 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "(x64
+@@ -95,9 +95,9 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "(x64
set(WTF_CPU_X86_64 1)
elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "(i[3-6]86|x86)")
set(WTF_CPU_X86 1)
diff --git a/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_assembler_ARM64Assembler.h b/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_assembler_ARM64Assembler.h
index 7ab0482cc0ed..de1bbc8fcb39 100644
--- a/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_assembler_ARM64Assembler.h
+++ b/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_assembler_ARM64Assembler.h
@@ -1,11 +1,11 @@
---- Source/JavaScriptCore/assembler/ARM64Assembler.h.orig 2018-03-05 09:28:05 UTC
+--- Source/JavaScriptCore/assembler/ARM64Assembler.h.orig 2018-08-21 16:06:10 UTC
+++ Source/JavaScriptCore/assembler/ARM64Assembler.h
-@@ -2856,6 +2856,8 @@ class ARM64Assembler { (public)
+@@ -2863,6 +2863,8 @@ class ARM64Assembler { (public)
{
#if OS(IOS)
sys_cache_control(kCacheFunctionPrepareForExecution, code, size);
+#elif OS(FREEBSD) || OS(NETBSD)
+ __clear_cache(code, reinterpret_cast<char*>(code) + size);
+ #elif OS(FUCHSIA)
+ zx_cache_flush(code, size, ZX_CACHE_FLUSH_INSN);
#elif OS(LINUX)
- size_t page = pageSize();
- uintptr_t current = reinterpret_cast<uintptr_t>(code);
diff --git a/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb b/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb
index 2d0f3b83d817..fc4d45ff7ffa 100644
--- a/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb
+++ b/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb
@@ -1,6 +1,6 @@
---- Source/JavaScriptCore/offlineasm/arm64.rb.orig 2018-06-01 22:16:58 UTC
+--- Source/JavaScriptCore/offlineasm/arm64.rb.orig 2018-10-27 21:20:55 UTC
+++ Source/JavaScriptCore/offlineasm/arm64.rb
-@@ -945,7 +945,7 @@ class Instruction
+@@ -938,7 +938,7 @@ class Instruction
$asm.puts "ldr #{operands[1].arm64Operand(:ptr)}, [#{operands[1].arm64Operand(:ptr)}, #{operands[0].asmLabel}@GOTPAGEOFF]"
# On Linux, use ELF GOT relocation specifiers.
diff --git a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Optional.h b/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Optional.h
index 01d37ea18ae0..930130f0c0b9 100644
--- a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Optional.h
+++ b/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Optional.h
@@ -1,6 +1,6 @@
---- Source/WTF/wtf/Optional.h.orig 2018-02-19 07:45:30 UTC
+--- Source/WTF/wtf/Optional.h.orig 2018-09-21 19:59:47 UTC
+++ Source/WTF/wtf/Optional.h
-@@ -291,12 +291,14 @@ struct nullopt_t
+@@ -277,12 +277,14 @@ struct nullopt_t
constexpr nullopt_t nullopt{nullopt_t::init()};
diff --git a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Platform.h b/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Platform.h
index 78ef620fcee7..8c180cda7030 100644
--- a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Platform.h
+++ b/www/webkit2-gtk3/files/patch-Source_WTF_wtf_Platform.h
@@ -1,6 +1,6 @@
---- Source/WTF/wtf/Platform.h.orig 2018-02-20 09:12:50 UTC
+--- Source/WTF/wtf/Platform.h.orig 2018-09-21 19:59:47 UTC
+++ Source/WTF/wtf/Platform.h
-@@ -182,6 +182,7 @@
+@@ -183,6 +183,7 @@
#elif defined(__ARM_ARCH_6__) \
|| defined(__ARM_ARCH_6J__) \
|| defined(__ARM_ARCH_6K__) \
@@ -8,7 +8,7 @@
|| defined(__ARM_ARCH_6Z__) \
|| defined(__ARM_ARCH_6ZK__) \
|| defined(__ARM_ARCH_6T2__) \
-@@ -229,6 +230,7 @@
+@@ -230,6 +231,7 @@
#elif defined(__ARM_ARCH_6J__) \
|| defined(__ARM_ARCH_6K__) \
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_PAL_pal_PlatformGTK.cmake b/www/webkit2-gtk3/files/patch-Source_WebCore_PAL_pal_PlatformGTK.cmake
index 1de1931f184b..972f08eb23e1 100644
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_PAL_pal_PlatformGTK.cmake
+++ b/www/webkit2-gtk3/files/patch-Source_WebCore_PAL_pal_PlatformGTK.cmake
@@ -1,6 +1,6 @@
---- Source/WebCore/PAL/pal/PlatformGTK.cmake.orig 2018-02-19 07:45:31 UTC
+--- Source/WebCore/PAL/pal/PlatformGTK.cmake.orig 2018-07-25 11:56:30 UTC
+++ Source/WebCore/PAL/pal/PlatformGTK.cmake
-@@ -12,6 +12,13 @@ list(APPEND PAL_SOURCES
+@@ -20,6 +20,13 @@ list(APPEND PAL_SOURCES
unix/LoggingUnix.cpp
)
@@ -12,5 +12,5 @@
+)
+
if (ENABLE_SUBTLE_CRYPTO)
- list(APPEND PAL_SOURCES
- crypto/tasn1/Utilities.cpp
+ list(APPEND PAL_PUBLIC_HEADERS
+ crypto/tasn1/Utilities.h
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.h b/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.h
deleted file mode 100644
index 827b6e2a3179..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h.orig 2018-02-19 07:45:32 UTC
-+++ Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h
-@@ -144,9 +144,9 @@ inline void FELighting::platformApplyNeon(const Lighti
- neonData.flags |= FLAG_CONE_EXPONENT_IS_1;
- } else {
- ASSERT(m_lightSource->type() == LS_DISTANT);
-- floatArguments.lightX = paintingData.lightVector.x();
-- floatArguments.lightY = paintingData.lightVector.y();
-- floatArguments.lightZ = paintingData.lightVector.z();
-+ floatArguments.lightX = paintingData.initialLightingData.lightVector.x();
-+ floatArguments.lightY = paintingData.initialLightingData.lightVector.y();
-+ floatArguments.lightZ = paintingData.initialLightingData.lightVector.z();
- floatArguments.padding2 = 1;
- }
-
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_egl_GLContextEGL.cpp b/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_egl_GLContextEGL.cpp
index 6fa3d11cb847..4dbd2acb2018 100644
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_egl_GLContextEGL.cpp
+++ b/www/webkit2-gtk3/files/patch-Source_WebCore_platform_graphics_egl_GLContextEGL.cpp
@@ -1,6 +1,6 @@
---- Source/WebCore/platform/graphics/egl/GLContextEGL.cpp.orig 2018-02-19 07:45:32 UTC
+--- Source/WebCore/platform/graphics/egl/GLContextEGL.cpp.orig 2018-07-25 11:56:31 UTC
+++ Source/WebCore/platform/graphics/egl/GLContextEGL.cpp
-@@ -44,6 +44,8 @@
+@@ -45,6 +45,8 @@
#include "OpenGLShims.h"
#endif
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_network_soup_SoupNetworkSession.h b/www/webkit2-gtk3/files/patch-Source_WebCore_platform_network_soup_SoupNetworkSession.h
index 464b0897ade3..fc71961dc937 100644
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_platform_network_soup_SoupNetworkSession.h
+++ b/www/webkit2-gtk3/files/patch-Source_WebCore_platform_network_soup_SoupNetworkSession.h
@@ -1,6 +1,6 @@
---- Source/WebCore/platform/network/soup/SoupNetworkSession.h.orig 2018-05-07 10:56:05.000000000 +0200
-+++ Source/WebCore/platform/network/soup/SoupNetworkSession.h 2018-05-14 21:15:28.165991000 +0200
-@@ -33,6 +33,8 @@
+--- Source/WebCore/platform/network/soup/SoupNetworkSession.h.orig 2018-09-06 11:51:34 UTC
++++ Source/WebCore/platform/network/soup/SoupNetworkSession.h
+@@ -34,6 +34,8 @@
#include <wtf/glib/GRefPtr.h>
#include <wtf/text/WTFString.h>
diff --git a/www/webkit2-gtk3/files/patch-Source__JavaScriptCore__assembler__ARMAssembler.h b/www/webkit2-gtk3/files/patch-Source__JavaScriptCore__assembler__ARMAssembler.h
index 393b67ec4cd0..028bf41963ac 100644
--- a/www/webkit2-gtk3/files/patch-Source__JavaScriptCore__assembler__ARMAssembler.h
+++ b/www/webkit2-gtk3/files/patch-Source__JavaScriptCore__assembler__ARMAssembler.h
@@ -1,6 +1,6 @@
---- Source/JavaScriptCore/assembler/ARMAssembler.h.orig 2018-02-19 07:45:14 UTC
+--- Source/JavaScriptCore/assembler/ARMAssembler.h.orig 2018-08-21 16:06:10 UTC
+++ Source/JavaScriptCore/assembler/ARMAssembler.h
-@@ -1202,6 +1202,8 @@ namespace JSC {
+@@ -1201,6 +1201,8 @@ namespace JSC {
linuxPageFlush(current, current + page);
linuxPageFlush(current, end);
diff --git a/www/webkit2-gtk3/files/patch-Source_bmalloc_bmalloc_BPlatform.h b/www/webkit2-gtk3/files/patch-Source_bmalloc_bmalloc_BPlatform.h
index 764ba39e6c50..5f019bee7a4c 100644
--- a/www/webkit2-gtk3/files/patch-Source_bmalloc_bmalloc_BPlatform.h
+++ b/www/webkit2-gtk3/files/patch-Source_bmalloc_bmalloc_BPlatform.h
@@ -1,6 +1,6 @@
---- Source/bmalloc/bmalloc/BPlatform.h.orig 2018-02-19 08:53:21 UTC
+--- Source/bmalloc/bmalloc/BPlatform.h.orig 2018-07-25 11:56:32 UTC
+++ Source/bmalloc/bmalloc/BPlatform.h
-@@ -139,6 +139,7 @@
+@@ -138,6 +138,7 @@
#elif defined(__ARM_ARCH_6__) \
|| defined(__ARM_ARCH_6J__) \
|| defined(__ARM_ARCH_6K__) \
diff --git a/www/webkit2-gtk3/pkg-plist b/www/webkit2-gtk3/pkg-plist
index 9b5320b6618a..99fce81e8a57 100644
--- a/www/webkit2-gtk3/pkg-plist
+++ b/www/webkit2-gtk3/pkg-plist
@@ -9,6 +9,16 @@ include/webkitgtk-4.0/JavaScriptCore/JSTypedArray.h
include/webkitgtk-4.0/JavaScriptCore/JSValueRef.h
include/webkitgtk-4.0/JavaScriptCore/JavaScript.h
include/webkitgtk-4.0/JavaScriptCore/WebKitAvailability.h
+include/webkitgtk-4.0/jsc/JSCAutocleanups.h
+include/webkitgtk-4.0/jsc/JSCClass.h
+include/webkitgtk-4.0/jsc/JSCContext.h
+include/webkitgtk-4.0/jsc/JSCDefines.h
+include/webkitgtk-4.0/jsc/JSCException.h
+include/webkitgtk-4.0/jsc/JSCValue.h
+include/webkitgtk-4.0/jsc/JSCVersion.h
+include/webkitgtk-4.0/jsc/JSCVirtualMachine.h
+include/webkitgtk-4.0/jsc/JSCWeakValue.h
+include/webkitgtk-4.0/jsc/jsc.h
include/webkitgtk-4.0/webkit2/WebKitApplicationInfo.h
include/webkitgtk-4.0/webkit2/WebKitAuthenticationRequest.h
include/webkitgtk-4.0/webkit2/WebKitAutocleanups.h
@@ -199,10 +209,10 @@ lib/girepository-1.0/WebKit2-4.0.typelib
lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
lib/libjavascriptcoregtk-4.0.so
lib/libjavascriptcoregtk-4.0.so.18
-lib/libjavascriptcoregtk-4.0.so.18.7.13
+lib/libjavascriptcoregtk-4.0.so.18.11.4
lib/libwebkit2gtk-4.0.so
lib/libwebkit2gtk-4.0.so.37
-lib/libwebkit2gtk-4.0.so.37.28.5
+lib/libwebkit2gtk-4.0.so.37.33.4
lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
libdata/pkgconfig/javascriptcoregtk-4.0.pc
libdata/pkgconfig/webkit2gtk-4.0.pc