aboutsummaryrefslogtreecommitdiff
path: root/www/webstone-ssl
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-03-12 19:55:49 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-03-12 19:55:49 +0000
commitc496f39624f160c4667c0970a45719c9e055fce7 (patch)
tree05e963ccec721de0953cc086091912ea5db7f7b2 /www/webstone-ssl
parent7a7b42800857f564c952e2598071e89cea5d48d9 (diff)
downloadports-c496f39624f160c4667c0970a45719c9e055fce7.tar.gz
ports-c496f39624f160c4667c0970a45719c9e055fce7.zip
Notes
Diffstat (limited to 'www/webstone-ssl')
-rw-r--r--www/webstone-ssl/Makefile3
-rw-r--r--www/webstone-ssl/files/patch-ab27
-rw-r--r--www/webstone-ssl/files/patch-ad25
3 files changed, 28 insertions, 27 deletions
diff --git a/www/webstone-ssl/Makefile b/www/webstone-ssl/Makefile
index 44ab356e89e4..88209bff9d93 100644
--- a/www/webstone-ssl/Makefile
+++ b/www/webstone-ssl/Makefile
@@ -22,6 +22,9 @@ WRKSRC= ${WRKDIR}/WebStone${PORTVERSION}/src
ALL_TARGET= install
NO_INSTALL_MANPAGES= yes
+CONFIGURE_ENV= "CFLAGS=${CFLAGS} -I${OPENSSLINC}" \
+ LIBS=-L${OPENSSLLIB}
+
do-install:
@${RMDIR} ${WRKSRC}/../bin/runs
@${MKDIR} ${PREFIX}/webstone-ssl/bin
diff --git a/www/webstone-ssl/files/patch-ab b/www/webstone-ssl/files/patch-ab
index d2f98058f3b5..a4170aef79e5 100644
--- a/www/webstone-ssl/files/patch-ab
+++ b/www/webstone-ssl/files/patch-ab
@@ -1,5 +1,28 @@
---- Makefile.in.orig Mon Sep 4 18:52:21 2000
-+++ Makefile.in Mon Sep 4 18:52:45 2000
+--- Makefile.in.orig Fri Jun 16 05:49:19 2000
++++ Makefile.in Tue Mar 13 04:51:41 2001
+@@ -29,7 +29,7 @@
+ VERSION = @VERSION@
+
+ CC = @CC@
+-LIBS = @LIBS@ -lssl -lcrypto #-lm
++LIBS = @LIBS@ -lssl -lcrypto -lcompat #-lm
+ LDFLAGS = @LDFLAGS@
+ INCLUDES =
+ CFLAGS = @CFLAGS@ -DSTONE_SSL
+@@ -47,11 +47,11 @@
+ MAIN3 = genrand.c
+
+ MASTERSRCS = timefunc.c bench.c parse_file_list.c statistics.c \
+- errexit.c sysdep.c
++ errexit.c sysdep.c random.c
+
+ STONESRCS = timefunc.c get.c \
+ parse_file_list.c bench.c statistics.c errexit.c \
+- sysdep.c
++ sysdep.c random.c
+
+ COMPILE = $(CC) $(CFLAGS) $(DEFS) $(INCLUDES)
+
@@ -64,9 +64,9 @@
.SUFFIXES:
.SUFFIXES: .c .o
diff --git a/www/webstone-ssl/files/patch-ad b/www/webstone-ssl/files/patch-ad
deleted file mode 100644
index 2f485df1ef9e..000000000000
--- a/www/webstone-ssl/files/patch-ad
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.in.orig Mon Oct 30 14:40:23 2000
-+++ Makefile.in Mon Oct 30 14:45:31 2000
-@@ -29,7 +29,7 @@
- VERSION = @VERSION@
-
- CC = @CC@
--LIBS = @LIBS@ -lssl -lcrypto #-lm
-+LIBS = @LIBS@ -lssl -lcrypto -lcompat #-lm
- LDFLAGS = @LDFLAGS@
- INCLUDES =
- CFLAGS = @CFLAGS@ -DSTONE_SSL
-@@ -47,11 +47,11 @@
- MAIN3 = genrand.c
-
- MASTERSRCS = timefunc.c bench.c parse_file_list.c statistics.c \
-- errexit.c sysdep.c
-+ errexit.c sysdep.c random.c
-
- STONESRCS = timefunc.c get.c \
- parse_file_list.c bench.c statistics.c errexit.c \
-- sysdep.c
-+ sysdep.c random.c
-
- COMPILE = $(CC) $(CFLAGS) $(DEFS) $(INCLUDES)
-