aboutsummaryrefslogtreecommitdiff
path: root/www/winhelpcgi
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-16 22:35:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-16 22:35:34 +0000
commit1fac1e83296f7aa8626c3654dd3492dec40ab0b4 (patch)
tree8208c9b3adfde83e6d50bd4273f314b7c094dca9 /www/winhelpcgi
parentc732dc381c8e9b6ed11b127835952b8bef43f553 (diff)
downloadports-1fac1e83296f7aa8626c3654dd3492dec40ab0b4.tar.gz
ports-1fac1e83296f7aa8626c3654dd3492dec40ab0b4.zip
Notes
Diffstat (limited to 'www/winhelpcgi')
-rw-r--r--www/winhelpcgi/Makefile29
-rw-r--r--www/winhelpcgi/distinfo4
-rw-r--r--www/winhelpcgi/files/patch-Makefile.am24
-rw-r--r--www/winhelpcgi/pkg-message19
-rw-r--r--www/winhelpcgi/pkg-plist3
5 files changed, 41 insertions, 38 deletions
diff --git a/www/winhelpcgi/Makefile b/www/winhelpcgi/Makefile
index d16b5c6b3576..62e898fe6c87 100644
--- a/www/winhelpcgi/Makefile
+++ b/www/winhelpcgi/Makefile
@@ -6,36 +6,35 @@
#
PORTNAME= winhelpcgi
-PORTVERSION= 0.93.1
+PORTVERSION= 0.99
CATEGORIES= www textproc
MASTER_SITES= http://www.herdsoft.com/ftp/
-DISTNAME= ${PORTNAME}_0.93-1
+DISTNAME= ${PORTNAME}_0.99-3
MAINTAINER= endx7@users.sf.net
COMMENT= A winhelp converter cgi program
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_AUTOMAKE_VER= 14
-AUTOMAKE_ARGS= --add-missing
+USE_GETTEXT= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64"
-.endif
-
-# get rid of symlinks
pre-patch:
- (cd ${WRKSRC}; ${RM} INSTALL install-sh mkinstalldirs missing COPYING)
+ (cd ${WRKSRC}; ${TOUCH} config.h)
post-build:
@${CAT} ${PKGDIR}/pkg-message | ${SED} -e 's:%%PREFIX%%:${PREFIX}:' > ${PKGMESSAGE}
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/winhelpcgi/winhelpcgi/winhelpcgi.cgi ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/www/winhelpcgi
+ ${INSTALL_PROGRAM} ${WRKSRC}/winhelpcgi/winhelpcgi.cgi ${PREFIX}/www/winhelpcgi
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/winhelpcgi/distinfo b/www/winhelpcgi/distinfo
index 2cfd888ca8d9..bb78d76609b7 100644
--- a/www/winhelpcgi/distinfo
+++ b/www/winhelpcgi/distinfo
@@ -1,2 +1,2 @@
-MD5 (winhelpcgi_0.93-1.tar.gz) = cf6df86cb484fbb506bc721f484ae896
-SIZE (winhelpcgi_0.93-1.tar.gz) = 239842
+MD5 (winhelpcgi_0.99-3.tar.gz) = 94cdc550d320a78a71293e4d71b8006f
+SIZE (winhelpcgi_0.99-3.tar.gz) = 305524
diff --git a/www/winhelpcgi/files/patch-Makefile.am b/www/winhelpcgi/files/patch-Makefile.am
index a8d5eb14f32a..9ddc698972a8 100644
--- a/www/winhelpcgi/files/patch-Makefile.am
+++ b/www/winhelpcgi/files/patch-Makefile.am
@@ -1,18 +1,10 @@
---- winhelpcgi/Makefile.am.orig Thu Apr 10 05:40:05 2003
-+++ winhelpcgi/Makefile.am Sat May 1 15:48:37 2004
-@@ -1,5 +1,5 @@
- ## Process this file using automake to create makefile.in
--INCLUDES = -I../include -I../include/linux
-+INCLUDES = -I../include -I../include/linux -I${LOCALBASE}/include
- #CFLAGS = -ggdb
-
- bin_PROGRAMS = winhelpcgi.cgi
-@@ -7,7 +7,7 @@
- winhelpcgi_cgi_SOURCES=dib2png.c wc_html.c wc_kwsrch.c winhelpcgi.c
- #winhelpcgi_cgi_LDFLAGS=-static
- #winhelpcgi_cgi_LDADD=-L../libhlpaccess -lhlpaccess -lpng -lz
--winhelpcgi_cgi_LDADD= \
-+winhelpcgi_cgi_LDADD= -L${LOCALBASE}/lib \
+--- winhelpcgi/Makefile.am.orig Fri Jun 11 22:31:21 2004
++++ winhelpcgi/Makefile.am Fri Jun 11 22:31:30 2004
+@@ -10,7 +10,7 @@
../libhlpaccess/libhlpaccess.a \
- -lpng -lz
+ -lpng -lz \
+ @LIBWMF_LIBS@ \
+- @INTLLIBS@
++ @INTLLIBS@ -lintl
+ noinst_HEADERS = dib2png.h winhelpcgi.h wmf2png.h
diff --git a/www/winhelpcgi/pkg-message b/www/winhelpcgi/pkg-message
index 71083e51a696..54493dac182c 100644
--- a/www/winhelpcgi/pkg-message
+++ b/www/winhelpcgi/pkg-message
@@ -1,7 +1,18 @@
-----------------------------------------------------------------
-winhelpcgi.cgi has been installed into %%PREFIX%%/bin
+winhelpcgi.cgi has been installed into %%PREFIX%%/www/winhelpcgi/
+
+You now need to copy winhelp files into %%PREFIX%%/www/winhelpcgi/
+
+You also need to somehow make your webserver aware of winhelpcgi.
+For example, the following config fragment would make apache aware
+of winhelpcgi:
+
+Alias /winhelpcgi %%PREFIX%%/www/winhelpcgi
+<Directory /usr/local/www/winhelpcgi>
+ AddHandler cgi-script .cgi
+ AllowOverride All
+ Options ExecCGI
+</Directory>
-You now need to copy winhelpcgi.cgi along with all winhelp files
-you wish for it to handle into the cgi-bin/ (or a subdir in
-cgi-bin/) of a http server that can handle cgi (such as Apache).
-----------------------------------------------------------------
+
diff --git a/www/winhelpcgi/pkg-plist b/www/winhelpcgi/pkg-plist
index c5cafc76a84c..055c8979bb81 100644
--- a/www/winhelpcgi/pkg-plist
+++ b/www/winhelpcgi/pkg-plist
@@ -1 +1,2 @@
-bin/winhelpcgi.cgi
+www/winhelpcgi/winhelpcgi.cgi
+@unexec rmdir %D/www/winhelpcgi 2>/dev/null || true