aboutsummaryrefslogtreecommitdiff
path: root/www/wsdlpull
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-16 02:41:17 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-16 02:41:17 +0000
commit6a24f1013bd2b6e7b382aed83144caaac91054b2 (patch)
tree4f060f1b6a1e0434354b0429e439aa5434b73019 /www/wsdlpull
parentf2ce7ac650e49366da55ce11f800f1447ad0c125 (diff)
downloadports-6a24f1013bd2b6e7b382aed83144caaac91054b2.tar.gz
ports-6a24f1013bd2b6e7b382aed83144caaac91054b2.zip
Notes
Diffstat (limited to 'www/wsdlpull')
-rw-r--r--www/wsdlpull/Makefile1
-rw-r--r--www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index c5bd1d7cddff..f109348db845 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -8,6 +8,7 @@
PORTNAME= wsdlpull
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
diff --git a/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp b/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
new file mode 100644
index 000000000000..0e7ae3c1354d
--- /dev/null
+++ b/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
@@ -0,0 +1,11 @@
+--- ./src/xmlpull/XmlUtils.cpp.orig 2009-12-16 02:36:41.855644800 +0000
++++ ./src/xmlpull/XmlUtils.cpp 2009-12-16 02:37:03.225260481 +0000
+@@ -212,7 +212,7 @@
+ // - use-case with a single '/' added (I am not sure this is conform to spec)
+ // #ifdef _WIN32
+ #if !defined(_WIN32)
+- unsigned int p;
++ size_t p;
+ if ((p=uri.find("file:///"))!=std::string::npos)
+ {
+ uri = uri.substr(p+7, uri.length()-p-7);