aboutsummaryrefslogtreecommitdiff
path: root/www/xaraya/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-07-14 11:48:43 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-07-14 11:48:43 +0000
commit0afea2ddc5ed8d5550f318bf055aa6801d094cd7 (patch)
treedc2a1d78dda9398638c86b86f5713df7c5a45e07 /www/xaraya/Makefile
parentda784807debbe51a4101e0306754ce27f09ac125 (diff)
downloadports-0afea2ddc5ed8d5550f318bf055aa6801d094cd7.tar.gz
ports-0afea2ddc5ed8d5550f318bf055aa6801d094cd7.zip
Notes
Diffstat (limited to 'www/xaraya/Makefile')
-rw-r--r--www/xaraya/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/www/xaraya/Makefile b/www/xaraya/Makefile
new file mode 100644
index 000000000000..30d78234ceb1
--- /dev/null
+++ b/www/xaraya/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: xaraya
+# Date created: 2005-07-10
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+# Try to specify WITH_PGSQL to use pgsql php extension. Mysql
+# extension would be used by default.
+
+PORTNAME= xaraya
+PORTVERSION= 1.0.0r3
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-1.0.0-rc3-base
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Framework to create fully dynamic Content Mangement Solutions
+
+.if defined(WITH_PGSQL)
+USE_PHP= pgsql
+.else
+USE_PHP= mysql
+.endif
+BROKEN_WITH_PHP= 5
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0-rc3
+
+# May user to override this
+XARAYADIR?= www/xaraya
+
+pre-install:
+ @${RM} -f ${TMPPLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${XARAYADIR}
+ ${CP} -r ${WRKSRC}/html/* ${PREFIX}/${XARAYADIR}
+.if !defined(NOTOOLS)
+ ${MKDIR} ${DATADIR}
+ ${CP} -r ${WRKSRC}/tools ${DATADIR}
+.endif
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${XARAYADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/docs/* ${DOCSDIR}
+ ${CP} ${WRKSRC}/INSTALL.txt ${WRKSRC}/LICENSE.txt \
+ ${WRKSRC}/CREDITS.txt ${DOCSDIR}
+.endif
+
+# Create plist
+post-install:
+ @${FIND} ${PREFIX}/${XARAYADIR} ! -type d -and ! -name install.php \
+ -and ! -name upgrade.php | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type f -and '(' -name install.php \
+ -or -name upgrade.php ')' | ${SED} -e \
+ 's,^${PREFIX}/\(.*\),@unexec rm -f %D/\1 >/dev/null 2>\&1 || true,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type d -and -path "*var*" | \
+ ${SED} -e 's,^${PREFIX}/\(.*\),@unexec rmdir %D/\1 >/dev/null 2>\&1 || true,' | \
+ ${SORT} -r >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${XARAYADIR} -type d -and ! -path "*var*" | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${FIND} ${DOCSDIR} ! -type d | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SED} -e \
+ 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.endif
+.if !defined(NOTOOLS)
+ @${FIND} ${DATADIR} ! -type d | ${SED} -e \
+ 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SED} -e \
+ 's,^${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>