aboutsummaryrefslogtreecommitdiff
path: root/www/xcache
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-12-03 09:11:45 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-12-03 09:11:45 +0000
commitdb97c65c0843fe1eda57ccf6e16b30eb79b86b69 (patch)
tree15ea61e0d5ecfab39255fe0ed99388a165ec652e /www/xcache
parent8cc27faac89c6af83aea6c25451c63f443bc8a61 (diff)
downloadports-db97c65c0843fe1eda57ccf6e16b30eb79b86b69.tar.gz
ports-db97c65c0843fe1eda57ccf6e16b30eb79b86b69.zip
Notes
Diffstat (limited to 'www/xcache')
-rw-r--r--www/xcache/Makefile7
-rw-r--r--www/xcache/distinfo6
-rw-r--r--www/xcache/files/patch-lock.c16
-rw-r--r--www/xcache/files/patch-xcache.c41
4 files changed, 6 insertions, 64 deletions
diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index d8a4d1eb9dd7..f85a81705810 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= xcache
-DISTVERSION= 1.2-beta3
-PORTREVISION= 1
+DISTVERSION= 1.2.0-rc2
CATEGORIES= www
MASTER_SITES= http://210.51.190.228/pub/XCache/Releases/ \
- http://210.51.190.228/pub/XCache/snapshots/
-DISTNAME= ${PORTNAME}-trunk-r278
+ http://210.51.190.228/pub/XCache/rc/${DISTVERSION}/
MAINTAINER= ale@FreeBSD.org
COMMENT= A fast and stable php opcode cacher
+USE_BZIP2= yes
USE_PHP= yes
USE_PHPIZE= yes
diff --git a/www/xcache/distinfo b/www/xcache/distinfo
index ab119df24e81..3160b301d0ea 100644
--- a/www/xcache/distinfo
+++ b/www/xcache/distinfo
@@ -1,3 +1,3 @@
-MD5 (xcache-trunk-r278.tar.gz) = 755e11d80a805cc88877814ddd503363
-SHA256 (xcache-trunk-r278.tar.gz) = 1a207afe138cca5299a9de9d2613dfd99bbfbab1e5ace74a3c4d8d0b152b30f0
-SIZE (xcache-trunk-r278.tar.gz) = 90692
+MD5 (xcache-1.2.0-rc2.tar.bz2) = 64c0b44d8e51dbce16c19e5f9b8f0320
+SHA256 (xcache-1.2.0-rc2.tar.bz2) = 44c4a864d1fe5d1e13d759dfdc35a25dee1b9a33c61517bfdf657bab03832afe
+SIZE (xcache-1.2.0-rc2.tar.bz2) = 79118
diff --git a/www/xcache/files/patch-lock.c b/www/xcache/files/patch-lock.c
deleted file mode 100644
index cce912f40c7b..000000000000
--- a/www/xcache/files/patch-lock.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- lock.c (revision 62)
-+++ lock.c (revision 282)
-@@ -92,5 +92,5 @@
- }
- size = strlen(tmpdir) + sizeof("/.xcache.lock") - 1 + 3 * 10 + 100;
-- myname = do_alloca(size);
-+ myname = malloc(size);
- snprintf(myname, size - 1, "%s%c.xcache.%d.%d.%d.lock", tmpdir, DEFAULT_SLASH, (int) getuid(), i ++, rand());
- pathname = myname;
-@@ -119,5 +119,5 @@
-
- if (myname) {
-- free_alloca(myname);
-+ free(myname);
- }
-
diff --git a/www/xcache/files/patch-xcache.c b/www/xcache/files/patch-xcache.c
deleted file mode 100644
index a5aa3c826f36..000000000000
--- a/www/xcache/files/patch-xcache.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- xcache.c (revision 278)
-+++ xcache.c (revision 283)
-@@ -1582,10 +1582,9 @@
- long id = 0;
-
-+ xcache_admin_auth_check(TSRMLS_C);
-+
- if (!xc_initized) {
-- php_error_docref(NULL TSRMLS_CC, E_WARNING, "XCache is not initized");
-- RETURN_FALSE;
-- }
--
-- xcache_admin_auth_check(TSRMLS_C);
-+ RETURN_NULL();
-+ }
-
- if (optype == XC_OP_COUNT) {
-@@ -2365,10 +2364,4 @@
- }
-
--/* dirty check */
--#if defined(COMPILE_DL_XCACHE) && (defined(ZEND_WIN32) || defined(__CYGWIN__) || defined(__MINGW32__))
--# define zend_append_version_info(x) do { } while (0)
--#else
--extern void zend_append_version_info(zend_extension *extension);
--#endif
- static int xc_zend_extension_startup(zend_extension *extension)
- {
-@@ -2377,5 +2370,4 @@
- return FAILURE;
- }
-- zend_append_version_info(extension);
- }
- return SUCCESS;
-@@ -2640,5 +2632,5 @@
- {
- if (xc_zend_extension_gotup) {
-- return FAILURE;
-+ return SUCCESS;
- }
- xc_zend_extension_gotup = 1;