aboutsummaryrefslogtreecommitdiff
path: root/www/xist/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-25 20:00:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-25 20:00:17 +0000
commitdf24b22a54cd9fe770f5865df745995180d43583 (patch)
tree18bcf755678fa61b1d0b85f181cfd2fe9e4f74b0 /www/xist/Makefile
parent7c506110c991c5e5576ac5d881ad6afdced7c8ce (diff)
downloadports-df24b22a54cd9fe770f5865df745995180d43583.tar.gz
ports-df24b22a54cd9fe770f5865df745995180d43583.zip
Notes
Diffstat (limited to 'www/xist/Makefile')
-rw-r--r--www/xist/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/www/xist/Makefile b/www/xist/Makefile
index 1b0a9d2735e3..d39aeb5c2c93 100644
--- a/www/xist/Makefile
+++ b/www/xist/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= xist
-PORTVERSION= 2.15.2
-PORTREVISION= 1
+PORTVERSION= 3.5
CATEGORIES= www python
MASTER_SITES= http://ftp.livinglogic.de/xist/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,17 +17,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An XML-based extensible HTML generator
RUN_DEPENDS= ${PYXML} \
- ${PYTHON_SITELIBDIR}/ll/__init__.py:${PORTSDIR}/devel/py-ll-core \
- ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}ll-core>=1.11.1:${PORTSDIR}/devel/py-ll-core \
+ ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.5:${PORTSDIR}/www/py-cssutils
-USE_PYTHON= 2.4+
-USE_PYDISTUTILS= yes
-USE_BZIP2= yes
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+USE_BZIP2= yes
PYDISTUTILS_PKGNAME= ll-xist
-post-install:
-.for file in doc2txt dtd2xsc tld2xsc
- @${MV} ${PREFIX}/bin/${file}.py ${PREFIX}/bin/${file}
-.endfor
-
.include <bsd.port.mk>