aboutsummaryrefslogtreecommitdiff
path: root/www/xshttpd-devel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-20 21:07:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-20 21:07:10 +0000
commit3cf127d733471d3d539fc81962d8ee87927ed711 (patch)
treef8bb608c8668681c5fd0fb772134d0cd802e2127 /www/xshttpd-devel/Makefile
parent5bccafd3f18249ec415ff52502ef05433b89fcff (diff)
Notes
Diffstat (limited to 'www/xshttpd-devel/Makefile')
-rw-r--r--www/xshttpd-devel/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index 7215463cc4fb..06476e479d9f 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.3b26
+DISTVERSION= 3.3b27
CATEGORIES= www
-MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/
+MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
+ ftp://mud.stack.nl/pub/xs-httpd/release/
DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
MAINTAINER= johans@stack.nl
@@ -23,11 +24,21 @@ MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
MAN5= httpd.conf.5 xsauth.5 xsscripts.5
USE_RC_SUBR= xshttpd.sh
+USE_REINPLACE= yes
+
+OPTIONS= SSL "Enable https support" On \
+ LDAP "Enable ldap support" Off \
+ PCRE "Enable pcre rewriting support" Off \
+ PERSISTENT_PERL "Enable persistent perl interpreter" Off
+
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
DATADIR= ${PREFIX}/www
CONFIGURE_ARGS+=--with-rootdir=${DATADIR}
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_SSL)
+.include <${PORTSDIR}/Mk/bsd.openssl.mk>
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ssl
.else
@@ -56,13 +67,14 @@ CONFIGURE_ARGS+=--with-pcre=no
.endif
post-patch:
-.for i in "man/httpd.1" "man/httpd.conf.5" "config/httpd.conf.sample" \
- "contrib/SSL-Makefile" "contrib/logrotate.sh"
- @${SED} \
+.for i in man/httpd.1 man/httpd.conf.5 config/httpd.conf.sample \
+ contrib/SSL-Makefile contrib/logrotate.sh
+ @${REINPLACE_CMD} \
-e 's|/wwwsys|${DATADIR}|g' \
-e 's|/usr/local/lib/httpd|${DATADIR}|g' \
- ${WRKSRC}/$i > ${WRKSRC}/$i.tmp
- @${MV} ${WRKSRC}/$i.tmp ${WRKSRC}/$i
+ -e 's|nobody|${WWWOWN}|g' \
+ -e 's|nogroup|${WWWGRP}|g' \
+ ${WRKSRC}/$i
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>