aboutsummaryrefslogtreecommitdiff
path: root/www/xshttpd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:04:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:04:31 +0000
commit5b696bd4102a099076f36e46479a34143c2a6f9a (patch)
treef56548d0774dcc70a620c04757738d00266e8530 /www/xshttpd
parent058bc54315021a93358f612734a8a22b45c2c07f (diff)
downloadports-5b696bd4102a099076f36e46479a34143c2a6f9a.tar.gz
ports-5b696bd4102a099076f36e46479a34143c2a6f9a.zip
Notes
Diffstat (limited to 'www/xshttpd')
-rw-r--r--www/xshttpd/Makefile68
-rw-r--r--www/xshttpd/distinfo2
-rw-r--r--www/xshttpd/files/xshttpd.sh.in29
-rw-r--r--www/xshttpd/pkg-descr23
-rw-r--r--www/xshttpd/pkg-plist70
5 files changed, 192 insertions, 0 deletions
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
new file mode 100644
index 000000000000..7215463cc4fb
--- /dev/null
+++ b/www/xshttpd/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: xshttpd
+# Date created: 29 June 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xshttpd
+DISTVERSION= 3.3b26
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/
+DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
+
+MAINTAINER= johans@stack.nl
+COMMENT= A webserver with CGI as own user and SSL suport
+
+CONFLICTS+= apache-[0-9]*
+
+GNU_CONFIGURE= yes
+
+MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
+ readxs.1 xsindex.1 xspasswd.1
+MAN5= httpd.conf.5 xsauth.5 xsscripts.5
+USE_RC_SUBR= xshttpd.sh
+
+# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
+DATADIR= ${PREFIX}/www
+CONFIGURE_ARGS+=--with-rootdir=${DATADIR}
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-ssl
+.else
+CONFIGURE_ARGS+=--without-ssl
+.endif
+
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-ldap
+.endif
+
+.if defined(WITH_PERSISTENT_PERL)
+USE_PERL5= yes
+CONFIGURE_ARGS+=--with-perl
+.else
+CONFIGURE_ARGS+=--without-perl
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-pcre=yes
+.else
+CONFIGURE_ARGS+=--with-pcre=no
+.endif
+
+post-patch:
+.for i in "man/httpd.1" "man/httpd.conf.5" "config/httpd.conf.sample" \
+ "contrib/SSL-Makefile" "contrib/logrotate.sh"
+ @${SED} \
+ -e 's|/wwwsys|${DATADIR}|g' \
+ -e 's|/usr/local/lib/httpd|${DATADIR}|g' \
+ ${WRKSRC}/$i > ${WRKSRC}/$i.tmp
+ @${MV} ${WRKSRC}/$i.tmp ${WRKSRC}/$i
+.endfor
+
+.include <bsd.port.mk>
diff --git a/www/xshttpd/distinfo b/www/xshttpd/distinfo
new file mode 100644
index 000000000000..8e732aafbf2a
--- /dev/null
+++ b/www/xshttpd/distinfo
@@ -0,0 +1,2 @@
+MD5 (xshttpd-33b26.tar.gz) = 704ed6e2be411c01207821ee94b84070
+SIZE (xshttpd-33b26.tar.gz) = 206980
diff --git a/www/xshttpd/files/xshttpd.sh.in b/www/xshttpd/files/xshttpd.sh.in
new file mode 100644
index 000000000000..cf038023446d
--- /dev/null
+++ b/www/xshttpd/files/xshttpd.sh.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: xshttpd
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable XS-HTTPD:
+# xshttpd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable XS-HTTPD.
+#
+
+. %%RC_SUBR%%
+
+name="xshttpd"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${xshttpd_enable="NO"}
+
+pidfile="/var/run/httpd.pid"
+command="%%PREFIX%%/bin/httpd"
+
+run_rc_command "$1"
diff --git a/www/xshttpd/pkg-descr b/www/xshttpd/pkg-descr
new file mode 100644
index 000000000000..47e5bba24d56
--- /dev/null
+++ b/www/xshttpd/pkg-descr
@@ -0,0 +1,23 @@
+XS-HTTPD is a WWW server that has the following features:
+
+- It is pronounced as "access-HTTP-daemon"
+- It is SMALL (very small in fact: a factor two to three smaller than
+ normal servers on disk and in memory)
+- It is FAST (because it is so small and does not do unnecessary things)
+- Uses very little CPU time
+- Configurable (configuration compiled in to make it small, but largely
+ overridable on the command line)
+- Runs user CGI binaries under their own user ID
+- Gets users' pages under their own user ID, allowing them to really
+ have protected pages (using the built-in authentication mechanism)
+- Does not fork for every connection (has a fixed number of servers),
+ only to replace a lost server (in case of timeouts).
+- Comes with some other useful programs
+- Offers Server-Side Includes for many common tasks, including built-in
+ page counters (text or graphical)
+- Supports PHP and other interpreted file formats
+- Supports automatic decompression to save diskspace and bandwidth
+- Serves SSL (https) and http connections through the same daemon
+- Full support for IPv6
+
+WWW: http://www.stack.nl/~johans/xs-httpd/
diff --git a/www/xshttpd/pkg-plist b/www/xshttpd/pkg-plist
new file mode 100644
index 000000000000..43fbea6c9009
--- /dev/null
+++ b/www/xshttpd/pkg-plist
@@ -0,0 +1,70 @@
+bin/clearxs
+bin/httpd
+bin/httpdc
+bin/readxs
+bin/xsindex
+bin/xspasswd
+%%DATADIR%%/cgi-bin/error
+%%DATADIR%%/cgi-bin/gfxcount
+%%DATADIR%%/cgi-bin/imagemap
+%%DATADIR%%/cgi-bin/xschpass
+%%DATADIR%%/contrib/SSL-Makefile
+%%DATADIR%%/contrib/logrotate.sh
+%%DATADIR%%/contrib/persistent.pl
+%%DATADIR%%/contrib/wwwstats.pl
+%%DATADIR%%/compress.methods.sample
+%%DATADIR%%/gfxcount/digital0.ppm
+%%DATADIR%%/gfxcount/digital1.ppm
+%%DATADIR%%/gfxcount/digital2.ppm
+%%DATADIR%%/gfxcount/digital3.ppm
+%%DATADIR%%/gfxcount/digital4.ppm
+%%DATADIR%%/gfxcount/digital5.ppm
+%%DATADIR%%/gfxcount/digital6.ppm
+%%DATADIR%%/gfxcount/digital7.ppm
+%%DATADIR%%/gfxcount/digital8.ppm
+%%DATADIR%%/gfxcount/digital9.ppm
+%%DATADIR%%/gfxcount/large0.ppm
+%%DATADIR%%/gfxcount/large1.ppm
+%%DATADIR%%/gfxcount/large2.ppm
+%%DATADIR%%/gfxcount/large3.ppm
+%%DATADIR%%/gfxcount/large4.ppm
+%%DATADIR%%/gfxcount/large5.ppm
+%%DATADIR%%/gfxcount/large6.ppm
+%%DATADIR%%/gfxcount/large7.ppm
+%%DATADIR%%/gfxcount/large8.ppm
+%%DATADIR%%/gfxcount/large9.ppm
+%%DATADIR%%/gfxcount/largecol0.ppm
+%%DATADIR%%/gfxcount/largecol1.ppm
+%%DATADIR%%/gfxcount/largecol2.ppm
+%%DATADIR%%/gfxcount/largecol3.ppm
+%%DATADIR%%/gfxcount/largecol4.ppm
+%%DATADIR%%/gfxcount/largecol5.ppm
+%%DATADIR%%/gfxcount/largecol6.ppm
+%%DATADIR%%/gfxcount/largecol7.ppm
+%%DATADIR%%/gfxcount/largecol8.ppm
+%%DATADIR%%/gfxcount/largecol9.ppm
+%%DATADIR%%/httpd.conf.sample
+%%DATADIR%%/icons/xs-audio.gif
+%%DATADIR%%/icons/xs-back.gif
+%%DATADIR%%/icons/xs-base.gif
+%%DATADIR%%/icons/xs-bin.gif
+%%DATADIR%%/icons/xs-dir.gif
+%%DATADIR%%/icons/xs-gif.gif
+%%DATADIR%%/icons/xs-html.gif
+%%DATADIR%%/icons/xs-image.gif
+%%DATADIR%%/icons/xs-jpeg.gif
+%%DATADIR%%/icons/xs-ps.gif
+%%DATADIR%%/icons/xs-tar.gif
+%%DATADIR%%/icons/xs-txt.gif
+%%DATADIR%%/icons/xs-unknown.gif
+%%DATADIR%%/icons/xs-video.gif
+%%DATADIR%%/icons/xs-zip.gif
+%%DATADIR%%/mime.index
+%%DATADIR%%/mime.types
+%%DATADIR%%/script.methods.sample
+@unexec rmdir %%DATADIR%%/cgi-bin 2> /dev/null || true
+@unexec rmdir %%DATADIR%%/htdocs 2> /dev/null || true
+@unexec rmdir %%DATADIR%%/logs 2> /dev/null || true
+@dirrm %%DATADIR%%/contrib
+@dirrm %%DATADIR%%/gfxcount
+@dirrm %%DATADIR%%/icons