aboutsummaryrefslogtreecommitdiff
path: root/www/zope29/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-01 00:35:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-01 00:35:12 +0000
commit8649d07bfcfaf4c8880f5c0fa7859fa04c869340 (patch)
treef287eeb4701b747ab9c38d787304e7a56d79ea46 /www/zope29/Makefile
parent6295540f44962ebe22aa4be7514a81517d8992f9 (diff)
downloadports-8649d07bfcfaf4c8880f5c0fa7859fa04c869340.tar.gz
ports-8649d07bfcfaf4c8880f5c0fa7859fa04c869340.zip
Notes
Diffstat (limited to 'www/zope29/Makefile')
-rw-r--r--www/zope29/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/www/zope29/Makefile b/www/zope29/Makefile
index d884d7864aa7..2cced07c35e7 100644
--- a/www/zope29/Makefile
+++ b/www/zope29/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zope29
-PORTVERSION= 2.9.7
-PORTREVISION= 1
+PORTVERSION= 2.9.9
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@@ -19,19 +18,11 @@ COMMENT= An object-based web application platform
USE_PYTHON= 2.4
USE_RC_SUBR= ${PORTNAME}.sh zeo29.sh
-LATEST_LINK= zope29
-# Note: the notes that follow reflect the decisions of prior maintainers
-# of this port. IOW, don't blame me if you don't like the way it's done.
-# Exceptions to this are marked as such.
-
-# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope29
-# Do not change anything below this line.
-
.if defined(INSTANCENAME)
ZOPEINSTANCENAME= ${INSTANCENAME}
.endif
@@ -73,12 +64,15 @@ post-configure:
-e 's,^.*LN.*PYTHON.*$$,,g' \
${WRKSRC}/${MAKEFILE}
+post-build:
+ -@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/
+
post-install:
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
${MKDIR} ${ZOPEBASEDIR}/Products
- ${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
+ ${INSTALL_DATA} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
.for d in lib bin doc skel Products
@@ -110,6 +104,6 @@ zeo:
@${CAT} ${WRKDIR}/zeo_message
pre-package:
- ${CP} ${WRKDIR}/package-pkg-message ${PKGMESSAGE}
+ ${INSTALL_DATA} ${WRKDIR}/package-pkg-message ${PKGMESSAGE}
.include <bsd.port.mk>