aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 19:45:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 19:45:32 +0000
commit079dc0ada76c6e0ca6e1ada3580c659a26ba1bec (patch)
treedffb661128120f6b3eda19ef67029821b5594102 /www
parent11fa4b1dd6be95c816d0a539a65782f0b8d6107f (diff)
downloadports-079dc0ada76c6e0ca6e1ada3580c659a26ba1bec.tar.gz
ports-079dc0ada76c6e0ca6e1ada3580c659a26ba1bec.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index ad51c12a1921..0e316242a38a 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -11,8 +11,12 @@ COMMENT= Node package manager
LICENSE= MIT
-OPTIONS_DEFINE= NODE_DEVEL
-NODE_DEVEL_DESC=Use www/node-devel instead of www/node
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= IOJS NODE NODE_DEVEL
+OPTIONS_DEFAULT=NODE
+IOJS_DESC= Use www/iojs as backend
+NODE_DESC= Use www/node as backend
+NODE_DEVEL_DESC=Use www/node-devel as backend
MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
NO_BUILD= yes
@@ -24,8 +28,9 @@ MANPREFIX= ${PREFIX}/lib/node_modules/npm
CPE_VENDOR= npmjs
CPE_PRODUCT= node_packaged_modules
+IOJS_RUN_DEPENDS= iojs>=1.0.0:${PORTSDIR}/www/iojs
NODE_DEVEL_RUN_DEPENDS= node-devel>=0.8.0:${PORTSDIR}/www/node-devel
-NODE_DEVEL_RUN_DEPENDS_OFF= node>=0.8.0:${PORTSDIR}/www/node
+NODE_RUN_DEPENDS= node>=0.8.0:${PORTSDIR}/www/node
post-patch:
@${REINPLACE_CMD} -e 's|node cli.js|& --cache ${WRKDIR}/.cache|' ${WRKSRC}/Makefile