aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-08 16:00:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-08 16:00:05 +0000
commit11fc070249523e4c27f8300b79892117cb93a5eb (patch)
tree4199232d1ce51ef2416bcaccabdb112171048b08 /www
parent9618c8187c4bcb432851334150fa26e71963bb2a (diff)
downloadports-11fc070249523e4c27f8300b79892117cb93a5eb.tar.gz
ports-11fc070249523e4c27f8300b79892117cb93a5eb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/davix/Makefile5
-rw-r--r--www/davix/distinfo6
-rw-r--r--www/davix/files/patch-test_functional_CMakeLists.txt14
-rw-r--r--www/davix/pkg-plist1
4 files changed, 13 insertions, 13 deletions
diff --git a/www/davix/Makefile b/www/davix/Makefile
index 634f9cc23956..e9080471b409 100644
--- a/www/davix/Makefile
+++ b/www/davix/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= davix
-DISTVERSION= 0.7.1
-PORTREVISION= 1
+DISTVERSION= 0.7.3
CATEGORIES= www
-MASTER_SITES= https://github.com/cern-fts/davix/releases/download/R_${DISTVERSION:S/./_/g}/
+MASTER_SITES= http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/${PORTNAME}/${DISTVERSION}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Make the task of managing files over HTTP-based protocols simple
diff --git a/www/davix/distinfo b/www/davix/distinfo
index 8d2003e73747..4b6c24089859 100644
--- a/www/davix/distinfo
+++ b/www/davix/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541295884
-SHA256 (davix-0.7.1.tar.gz) = 0d13c21d5d4ef9194313ae4cfba8095ac5a4272f276993c43103f833514f206b
-SIZE (davix-0.7.1.tar.gz) = 4336124
+TIMESTAMP = 1557330227
+SHA256 (davix-0.7.3.tar.gz) = cd46276e72c6a0da1e2ad30eb66ec509a4c023687767c62a66713fa8c23d328a
+SIZE (davix-0.7.3.tar.gz) = 4341865
diff --git a/www/davix/files/patch-test_functional_CMakeLists.txt b/www/davix/files/patch-test_functional_CMakeLists.txt
index c1496527e799..971baa83f590 100644
--- a/www/davix/files/patch-test_functional_CMakeLists.txt
+++ b/www/davix/files/patch-test_functional_CMakeLists.txt
@@ -1,11 +1,11 @@
---- test/functional/CMakeLists.txt.orig 2018-10-02 17:09:41 UTC
+--- test/functional/CMakeLists.txt.orig 2019-05-08 15:50:42 UTC
+++ test/functional/CMakeLists.txt
-@@ -83,7 +83,7 @@ add_library(test_davix_functional_lib ST
+@@ -81,7 +81,7 @@ add_library(test_davix_functional_lib ST
#target_link_libraries(test_mv libdavix test_davix_functional_lib)
- add_executable(tester ${src_tester})
--target_link_libraries(tester libdavix test_davix_functional_lib)
-+target_link_libraries(tester libdavix test_davix_functional_lib uuid)
+ add_executable(davix-tester ${src_tester})
+-target_link_libraries(davix-tester libdavix test_davix_functional_lib)
++target_link_libraries(davix-tester libdavix test_davix_functional_lib uuid)
- function(assert_not_empty var)
- if("${var}" STREQUAL "")
+ install(TARGETS davix-tester
+ DESTINATION ${BIN_INSTALL_DIR}/)
diff --git a/www/davix/pkg-plist b/www/davix/pkg-plist
index a27ece9021c6..4d9c2ab75d48 100644
--- a/www/davix/pkg-plist
+++ b/www/davix/pkg-plist
@@ -5,6 +5,7 @@ bin/davix-mkdir
bin/davix-mv
bin/davix-put
bin/davix-rm
+bin/davix-tester
bin/davix-unit-tests
include/davix/auth/davixauth.hpp
include/davix/auth/davixx509cred.hpp